summaryrefslogtreecommitdiffstats
path: root/tools/gmp
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-25 16:57:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-25 16:57:16 +0000
commitdd86bc73fb894a259bf8eca38c074128ad2eb40f (patch)
tree0c7d683eb56d86d604bb2021979b0ca2392f27cd /tools/gmp
parent3c9fcd2526e8a25a618851453ceb6a63e83c53b3 (diff)
downloadmaster-31e0f0ae-dd86bc73fb894a259bf8eca38c074128ad2eb40f.tar.gz
master-31e0f0ae-dd86bc73fb894a259bf8eca38c074128ad2eb40f.tar.bz2
master-31e0f0ae-dd86bc73fb894a259bf8eca38c074128ad2eb40f.zip
tools: Fix compilation on x32 host
Compiling the host tools on the new x32 architecture (which is an ILP32 ELF32 system on an amd64 CPU) fails for various reasons. gmp: pull same fix I applied to OpenADK, which was inspired by the fix in the Debian source package mtd-utils: write a workaround myself; only affects x32, but the use of llseek is dangerous according to the manpage, so the guard ifdef should probably go away findutils: pull fix straight from the Debian source packae Signed-off-by: Thorsten Glaser <tg@mirbsd.org> SVN-Revision: 43060
Diffstat (limited to 'tools/gmp')
-rw-r--r--tools/gmp/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/gmp/Makefile b/tools/gmp/Makefile
index 463cbe9f5c..b1976d0cc3 100644
--- a/tools/gmp/Makefile
+++ b/tools/gmp/Makefile
@@ -27,4 +27,8 @@ HOST_CONFIGURE_ARGS += \
--enable-cxx \
--enable-mpbsd
+ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
+HOST_CONFIGURE_ARGS += ABI=x32
+endif
+
$(eval $(call HostBuild))