summaryrefslogtreecommitdiffstats
path: root/tools/gengetopt
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-11-30 09:51:48 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-11-30 09:51:48 +0000
commit5ec23daa26e4e8551a1e19f6e8c566723fb5838a (patch)
treea9d652eecba359aa41b34b72a6eeeb48114be2d9 /tools/gengetopt
parentc595a596801079592ad4bb64cd311faa0aad2abb (diff)
downloadmaster-31e0f0ae-5ec23daa26e4e8551a1e19f6e8c566723fb5838a.tar.gz
master-31e0f0ae-5ec23daa26e4e8551a1e19f6e8c566723fb5838a.tar.bz2
master-31e0f0ae-5ec23daa26e4e8551a1e19f6e8c566723fb5838a.zip
add gengetopt
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 43437
Diffstat (limited to 'tools/gengetopt')
-rw-r--r--tools/gengetopt/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/tools/gengetopt/Makefile b/tools/gengetopt/Makefile
new file mode 100644
index 0000000000..a66fbe6605
--- /dev/null
+++ b/tools/gengetopt/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licengengetopt under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gengetopt
+PKG_VERSION:=2.22.6
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
+PKG_MD5SUM:=29749a48dda69277ab969c510597a14e
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/src/gengetopt $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/gengetopt
+endef
+
+$(eval $(call HostBuild))