summaryrefslogtreecommitdiffstats
path: root/tools/genext2fs/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-04-20 13:58:22 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-04-20 13:58:22 +0000
commit8c68c104eaba65273280c7a4727fbb10ab10f5af (patch)
treefa13d48b950e292741182a842a0d385c8eea6da9 /tools/genext2fs/Makefile
parent0ee950491197e8c528249d64ca3276b39bad0ddd (diff)
downloadmaster-31e0f0ae-8c68c104eaba65273280c7a4727fbb10ab10f5af.tar.gz
master-31e0f0ae-8c68c104eaba65273280c7a4727fbb10ab10f5af.tar.bz2
master-31e0f0ae-8c68c104eaba65273280c7a4727fbb10ab10f5af.zip
tools: drop unused genext2fs
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 45518
Diffstat (limited to 'tools/genext2fs/Makefile')
-rw-r--r--tools/genext2fs/Makefile51
1 files changed, 0 insertions, 51 deletions
diff --git a/tools/genext2fs/Makefile b/tools/genext2fs/Makefile
deleted file mode 100644
index ad941c71ac..0000000000
--- a/tools/genext2fs/Makefile
+++ /dev/null
@@ -1,51 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=genext2fs
-PKG_VERSION:=1.4.1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/genext2fs
-PKG_MD5SUM:=b7b6361bcce2cedff1ae437fadafe53b
-
-include $(INCLUDE_DIR)/host-build.mk
-
-HOST_CONFIGURE_ARGS = \
- --target=$(GNU_HOST_NAME) \
- --host=$(GNU_HOST_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --sbindir=/usr/sbin \
- --libexecdir=/usr/lib \
- --sysconfdir=/etc \
- --datadir=/usr/share \
- --localstatedir=/var \
- --mandir=/usr/man \
- --infodir=/usr/info \
-
-define Host/Compile
- $(MAKE) -C $(HOST_BUILD_DIR) \
- CFLAGS="$(HOST_CFLAGS)" \
- LDFLAGS="$(HOST_LDFLAGS)" \
- all
-endef
-
-define Host/Install
- install -m0755 $(HOST_BUILD_DIR)/genext2fs $(STAGING_DIR_HOST)/bin/
-endef
-
-define Host/Clean
- rm -f $(STAGING_DIR_HOST)/bin/genext2fs
-endef
-
-$(eval $(call HostBuild))