summaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-11-26 08:59:22 +0000
committerJohn Crispin <john@openwrt.org>2014-11-26 08:59:22 +0000
commitf318ae995a991b37337bd0dbd8180d4b219e69d7 (patch)
treea21ec3308382ed5e27e0a68889bd79ef013924b9 /tools/firmware-utils/Makefile
parent9a70c8ef9b4978f169adb40231987ec44af3e77d (diff)
downloadmaster-31e0f0ae-f318ae995a991b37337bd0dbd8180d4b219e69d7.tar.gz
master-31e0f0ae-f318ae995a991b37337bd0dbd8180d4b219e69d7.tar.bz2
master-31e0f0ae-f318ae995a991b37337bd0dbd8180d4b219e69d7.zip
firmware-utils: add new tool tplink-safeloader for the new TP-LINK Pharos devices (CPE210/220/510/520)
The new TP-LINK Pharos series uses a new bootloader, the "TP-LINK Safeloader". It uses an advanced firmware image format, containing an image partition table and a flash partition table (and image partitions are mapped to the corresponding flash partitions). The exact image format is documented in the source code. Furthermore, the bootloader expects the kernel image as an ELF executable. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> SVN-Revision: 43384
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 65b7c1530e..988c6256af 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -41,6 +41,7 @@ define Host/Compile
$(call cc,mkplanexfw sha1)
$(call cc,mktplinkfw md5)
$(call cc,mktplinkfw2 md5)
+ $(call cc,tplink-safeloader md5, -Wall)
$(call cc,pc1crypt)
$(call cc,osbridge-crc)
$(call cc,wrt400n cyg_crc32)