summaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-06 23:41:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-06 23:41:38 +0000
commitebdcc6d40c1abb39c248b90e83f653ffd429578a (patch)
tree1d8972d0bbb00d81613edd4c1f7de1f63702c988 /tools/firmware-utils/Makefile
parent98910471a788906e794d00793e82d089cad58d1a (diff)
downloadmaster-31e0f0ae-ebdcc6d40c1abb39c248b90e83f653ffd429578a.tar.gz
master-31e0f0ae-ebdcc6d40c1abb39c248b90e83f653ffd429578a.tar.bz2
master-31e0f0ae-ebdcc6d40c1abb39c248b90e83f653ffd429578a.zip
move target/utils to tools/firmware-utils
SVN-Revision: 5702
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
new file mode 100644
index 0000000000..7b612aeac1
--- /dev/null
+++ b/tools/firmware-utils/Makefile
@@ -0,0 +1,32 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/host-build.mk
+
+PKG_NAME := firmware-utils
+PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/firmware-utils
+
+CFLAGS := -O2 -I $(STAGING_DIR)/include-host -include endian.h
+
+define cc
+ $(CC) $(CFLAGS) -o $(PKG_BUILD_DIR)/bin/$(1) src/$(1).c
+endef
+
+define Build/Compile
+ mkdir -p $(PKG_BUILD_DIR)/bin
+ $(call cc,addpattern)
+ $(call cc,trx)
+ $(call cc,motorola-bin)
+ $(call cc,dgfirmware)
+ $(call cc,trx2usr)
+endef
+
+define Build/Install
+ $(CP) $(PKG_BUILD_DIR)/bin/* $(STAGING_DIR)/bin
+endef
+
+$(eval $(call HostBuild))