summaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-10 19:27:08 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-10 19:27:08 +0000
commite2e55d7acd5962a238da38df4399ee7cb7799978 (patch)
tree86c848aafc43a8dbf67788ea6a5060726d7fe34f /tools/firmware-utils/Makefile
parenta7568eb87595f0097a1c4bb4e1c0ce033f7fd350 (diff)
downloadmaster-31e0f0ae-e2e55d7acd5962a238da38df4399ee7cb7799978.tar.gz
master-31e0f0ae-e2e55d7acd5962a238da38df4399ee7cb7799978.tar.bz2
master-31e0f0ae-e2e55d7acd5962a238da38df4399ee7cb7799978.zip
firmware-utils: link statically
SVN-Revision: 33117
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 05b588f3b5..640dd23ee5 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/kernel.mk
define cc
- $(HOSTCC) $(HOST_CFLAGS) -include endian.h -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
+ $(HOSTCC) $(HOST_CFLAGS) -include endian.h -static -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
endef
define Host/Compile