summaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-12 12:34:30 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-12 12:34:30 +0000
commitcf1698c6370d6a64f5f70a2dc5652d1fbc62afc3 (patch)
tree8dea115df7f768723281ea58c0ce7d0c4180182b /tools/firmware-utils/Makefile
parent095fe8743b64a47ea2b13642934348f914d2a2bb (diff)
downloadmaster-31e0f0ae-cf1698c6370d6a64f5f70a2dc5652d1fbc62afc3.tar.gz
master-31e0f0ae-cf1698c6370d6a64f5f70a2dc5652d1fbc62afc3.tar.bz2
master-31e0f0ae-cf1698c6370d6a64f5f70a2dc5652d1fbc62afc3.zip
use HOST_STATIC_LINKING instead of hardcoding -static
SVN-Revision: 33140
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 640dd23ee5..2994660760 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/kernel.mk
define cc
- $(HOSTCC) $(HOST_CFLAGS) -include endian.h -static -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
+ $(HOSTCC) $(HOST_CFLAGS) -include endian.h $(HOST_STATIC_LINKING) -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
endef
define Host/Compile