summaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-02-14 17:48:04 +0000
committerJohn Crispin <john@openwrt.org>2012-02-14 17:48:04 +0000
commitcd1a204365fff2639329c28c1b986f3a4e7246d4 (patch)
tree110a78ac8772fcb23ba40e73117c18271957f642 /tools/firmware-utils/Makefile
parent17e17170332f0fba7a53dbb0bd7480a639cf8ef7 (diff)
downloadmaster-31e0f0ae-cd1a204365fff2639329c28c1b986f3a4e7246d4.tar.gz
master-31e0f0ae-cd1a204365fff2639329c28c1b986f3a4e7246d4.tar.bz2
master-31e0f0ae-cd1a204365fff2639329c28c1b986f3a4e7246d4.zip
Support booting the Speedport W502V using BRN-BOOT.
While the disadvantage is less available flash space, it's easy and safe to flash without opening the device. Going back to the original firmware is also possible. This patch add two firmware utilities, mkbrncmdline and mkbrnboot. mkbrncmdline patches the uncompressed kernel so the registeres a0 to a3 are initialized and the memory size is passed in. mkbrnboot takes the lzma compressed kernel and squashfs images and creates a firmware image that can be flashed using the BRN-BOOT recovery kernel, which is booted by holding both buttons when powering up the device and will listen on http://192.168.2.1. The firmware file from bin/lantiq/ to use is openwrt-lantiq-danube-ARV4525PW-BRNDTW502-brnImage The BRN-BOOT recovery kernel does size-check the image, so if it's too big to fit into flash it will complain accordingly. A second patch is needed to make the wired network interface work since there is no u-boot to pre-initialise it. Signed-off-by: Tobias Diedrich <ranma+openwrt@tdiedrich.de> SVN-Revision: 30532
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index cd7531f216..4364223546 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -55,6 +55,8 @@ define Host/Compile
$(call cc,buffalo-tftp buffalo-lib, -Wall)
$(call cc,mkwrgimg md5, -Wall)
$(call cc,mkedimaximg)
+ $(call cc,mkbrncmdline)
+ $(call cc,mkbrnimg)
endef
define Host/Install