summaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2016-02-01 12:42:00 +0000
committerRafał Miłecki <zajec5@gmail.com>2016-02-01 12:42:00 +0000
commit590c7825c191800b98cf00a431e95bba07c64604 (patch)
treec085ab1b5f0ca2e20dee4d8fee327df9f7a83876 /tools/firmware-utils/Makefile
parent9220dd5d368efb81132007cca93eb783fd7b48dc (diff)
downloadmaster-31e0f0ae-590c7825c191800b98cf00a431e95bba07c64604.tar.gz
master-31e0f0ae-590c7825c191800b98cf00a431e95bba07c64604.tar.bz2
master-31e0f0ae-590c7825c191800b98cf00a431e95bba07c64604.zip
firmware-utils: add oseama tool for creating Seama entities
It has an important feature (compared to seama) of using multiple input files, aligning them and padding zeroes until reaching a specified absolute offset. This is needed for a proper flash layout on NAND. We want kernel partition to be big enough to handle future updates without a need to resize it and wipe whole "ubi" partition. It's important as we don't want to lose block counters. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 48601
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index dc922b0360..7a4403cba2 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -64,6 +64,7 @@ define Host/Compile
$(call cc,mkdapimg)
$(call cc, mkcameofw, -Wall)
$(call cc,seama md5)
+ $(call cc,oseama md5, -Wall)
$(call cc,fix-u-media-header cyg_crc32,-Wall)
$(call cc,hcsmakeimage bcmalgo)
$(call cc,mkporayfw, -Wall)