summaryrefslogtreecommitdiffstats
path: root/tools/expat
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-07-10 19:42:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-07-10 19:42:05 +0000
commitae706ea6b6de775de99019a61fd335e0aba5122c (patch)
treecec8e8fa00a0707281f059c2def39fed19fffbfc /tools/expat
parent91c3ad77cf476aedb4370d4af0d456e86602c0bc (diff)
downloadmaster-31e0f0ae-ae706ea6b6de775de99019a61fd335e0aba5122c.tar.gz
master-31e0f0ae-ae706ea6b6de775de99019a61fd335e0aba5122c.tar.bz2
master-31e0f0ae-ae706ea6b6de775de99019a61fd335e0aba5122c.zip
tools: add expat library (to be used by gdb)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 46297
Diffstat (limited to 'tools/expat')
-rw-r--r--tools/expat/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/tools/expat/Makefile b/tools/expat/Makefile
new file mode 100644
index 0000000000..dfd5f286cd
--- /dev/null
+++ b/tools/expat/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2006-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=expat
+PKG_VERSION:=2.1.0
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=dd7dab7a5fea97d2a6a43f511449b7cd
+PKG_SOURCE_URL:=@SF/expat
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Install
+ $(MAKE) -C $(HOST_BUILD_DIR) install
+endef
+
+$(eval $(call HostBuild))