summaryrefslogtreecommitdiffstats
path: root/tools/elftosb/Makefile
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2013-10-14 19:45:31 +0000
committerZoltan Herpai <wigyori@uid0.hu>2013-10-14 19:45:31 +0000
commit4da854bcd00842894558aba10b3521d7171ba1e3 (patch)
tree615349055b0b8a264abe1b3752bf39288034dd00 /tools/elftosb/Makefile
parente90e74000aa041705dca0c621bbd45f81636f393 (diff)
downloadmaster-31e0f0ae-4da854bcd00842894558aba10b3521d7171ba1e3.tar.gz
master-31e0f0ae-4da854bcd00842894558aba10b3521d7171ba1e3.tar.bz2
master-31e0f0ae-4da854bcd00842894558aba10b3521d7171ba1e3.zip
elftosb: support static linking
Signed-off-by: Michael Heimpold <mhei@heimpold.de> Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> SVN-Revision: 38400
Diffstat (limited to 'tools/elftosb/Makefile')
-rw-r--r--tools/elftosb/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/tools/elftosb/Makefile b/tools/elftosb/Makefile
index c063217d0b..6f9b963975 100644
--- a/tools/elftosb/Makefile
+++ b/tools/elftosb/Makefile
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -13,19 +13,14 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://repository.timesys.com/buildsources/e/elftosb/elftosb-10.12.01/
PKG_MD5SUM:=e8005d606c1e0bb3507c82f6eceb3056
-HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)
-
include $(INCLUDE_DIR)/host-build.mk
define Host/Compile
- $(MAKE) -C $(HOST_BUILD_DIR) -f makefile LDFLAGS="$(HOST_STATIC_LINKING)"
+ $(MAKE) -C $(HOST_BUILD_DIR) LDFLAGS="$(HOST_LDFLAGS) $(HOST_STATIC_LINKING)"
endef
define Host/Install
$(INSTALL_BIN) $(HOST_BUILD_DIR)/bld/linux/elftosb $(STAGING_DIR_HOST)/bin/elftosb
endef
-define Host/Clean
-endef
-
$(eval $(call HostBuild))