summaryrefslogtreecommitdiffstats
path: root/tools/dosfstools
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-01-11 22:15:11 +0000
committerNicolas Thill <nico@openwrt.org>2015-01-11 22:15:11 +0000
commita0191c9b64d03f1548e5d1f33e2963a785f743f6 (patch)
tree09acf345c2fa70c3106c3048335aece4a9c20811 /tools/dosfstools
parenta46965888a151374d8f3126960aaff7c45e2632b (diff)
downloadmaster-31e0f0ae-a0191c9b64d03f1548e5d1f33e2963a785f743f6.tar.gz
master-31e0f0ae-a0191c9b64d03f1548e5d1f33e2963a785f743f6.tar.bz2
master-31e0f0ae-a0191c9b64d03f1548e5d1f33e2963a785f743f6.zip
dosfstools: update to 3.0.26
Signed-off-by: Nicolas Thill <nico@openwrt.org> SVN-Revision: 43942
Diffstat (limited to 'tools/dosfstools')
-rw-r--r--tools/dosfstools/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/tools/dosfstools/Makefile b/tools/dosfstools/Makefile
index c58248910b..f91d1b1015 100644
--- a/tools/dosfstools/Makefile
+++ b/tools/dosfstools/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2012 OpenWrt.org
+# Copyright (C) 2012-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,11 +7,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=dosfstools
-PKG_VERSION:=3.0.7
-PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
-PKG_SOURCE_URL:=http://dosfstools.sourcearchive.com/downloads/3.0.7/
-PKG_MD5SUM:=5d4d97c79e8dae60bb08c2fba36c94d6
-PKG_CAT:=zcat
+PKG_VERSION:=3.0.26
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=http://daniel-baumann.ch/files/software/dosfstools/
+PKG_MD5SUM:=45012f5f56f2aae3afcd62120b9e5a08
include $(INCLUDE_DIR)/host-build.mk
@@ -20,11 +20,12 @@ define Host/Compile
endef
define Host/Install
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/mkdosfs $(STAGING_DIR_HOST)/bin/
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/mkfs.fat $(STAGING_DIR_HOST)/bin/
+ $(LN) mkfs.fat $(STAGING_DIR_HOST)/bin/mkdosfs
endef
define Host/Clean
- rm -f $(STAGING_DIR_HOST)/bin/mkdosfs
+ rm -f $(STAGING_DIR_HOST)/bin/mk{dosfs,fs.fat}
endef
$(eval $(call HostBuild))