summaryrefslogtreecommitdiffstats
path: root/tools/dosfstools
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-07-24 20:39:00 +0000
committerJohn Crispin <john@openwrt.org>2012-07-24 20:39:00 +0000
commit25482a60b34d4c4c2d6ad1dd3c65bf1e8be79472 (patch)
tree9e68ef2d0faa29e7e28defbaab760997f53af9ec /tools/dosfstools
parent5e52619b763af5cff25d11865c29f84fdf8c5a25 (diff)
downloadmaster-31e0f0ae-25482a60b34d4c4c2d6ad1dd3c65bf1e8be79472.tar.gz
master-31e0f0ae-25482a60b34d4c4c2d6ad1dd3c65bf1e8be79472.tar.bz2
master-31e0f0ae-25482a60b34d4c4c2d6ad1dd3c65bf1e8be79472.zip
add mktools and dosfstools which are needed for the raspberry pi
Signed-off-by: Ian Ridge <ianridge [at] gmail.com> SVN-Revision: 32824
Diffstat (limited to 'tools/dosfstools')
-rw-r--r--tools/dosfstools/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/tools/dosfstools/Makefile b/tools/dosfstools/Makefile
new file mode 100644
index 0000000000..88ac057f16
--- /dev/null
+++ b/tools/dosfstools/Makefile
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=dosfstools
+PKG_VERSION:=3.0.7
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
+PKG_SOURCE_URL:=http://dosfstools.sourcearchive.com/downloads/3.0.7/
+PKG_MD5SUM:=5d4d97c79e8dae60bb08c2fba36c94d6
+PKG_CAT:=zcat
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)"
+endef
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/mkdosfs $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/mkdosfs
+endef
+
+$(eval $(call HostBuild))