summaryrefslogtreecommitdiffstats
path: root/tools/bison/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-09-26 21:10:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-09-26 21:10:48 +0000
commit877f2972d4d8f63644f18688cff7efd7ce280f2b (patch)
treea60b94d8b80265dad50a68a8dd20e6145a8ca487 /tools/bison/Makefile
parenta883639e9221f59c91e7bf3cd56615b79e50518f (diff)
downloadmaster-31e0f0ae-877f2972d4d8f63644f18688cff7efd7ce280f2b.tar.gz
master-31e0f0ae-877f2972d4d8f63644f18688cff7efd7ce280f2b.tar.bz2
master-31e0f0ae-877f2972d4d8f63644f18688cff7efd7ce280f2b.zip
bison: replace the yacc script with one that does not hardcode the path (fixes #20605)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 47050
Diffstat (limited to 'tools/bison/Makefile')
-rw-r--r--tools/bison/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/bison/Makefile b/tools/bison/Makefile
index 10d8720484..256512116f 100644
--- a/tools/bison/Makefile
+++ b/tools/bison/Makefile
@@ -23,4 +23,9 @@ define Host/Clean
$(call Host/Clean/Default)
endef
+define Host/Install
+ $(call Host/Install/Default)
+ $(INSTALL_BIN) ./scripts/yacc $(STAGING_DIR_HOST)/bin/yacc
+endef
+
$(eval $(call HostBuild))