summaryrefslogtreecommitdiffstats
path: root/tools/automake
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-13 07:49:01 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-13 07:49:01 +0000
commit73a1f3597b0d4ba34306e8ce5f20957f1a1de7f1 (patch)
treeee935ab34f117f8fd425cc8867c451ee3a78cc34 /tools/automake
parent6dec519be7a9814d6c93aa8cfb9bcb025708b1b1 (diff)
downloadmaster-31e0f0ae-73a1f3597b0d4ba34306e8ce5f20957f1a1de7f1.tar.gz
master-31e0f0ae-73a1f3597b0d4ba34306e8ce5f20957f1a1de7f1.tar.bz2
master-31e0f0ae-73a1f3597b0d4ba34306e8ce5f20957f1a1de7f1.zip
tools: bootstrap automake to pickup the correct in-tree autoconf
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 43958
Diffstat (limited to 'tools/automake')
-rw-r--r--tools/automake/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/automake/Makefile b/tools/automake/Makefile
index 300bee21ea..8c390d48de 100644
--- a/tools/automake/Makefile
+++ b/tools/automake/Makefile
@@ -18,6 +18,11 @@ include $(INCLUDE_DIR)/host-build.mk
HOST_CONFIGURE_ARGS += --datarootdir=$(STAGING_DIR_HOST)/share
HOST_CONFIGURE_VARS += am_cv_prog_PERL_ithreads=no
+define Host/Configure
+ (cd $(HOST_BUILD_DIR); $(AM_TOOL_PATHS) STAGING_DIR="" ./bootstrap.sh)
+ $(call Host/Configure/Default)
+endef
+
define Host/Install
# remove old automake resources to avoid version conflicts
rm -rf $(STAGING_DIR_HOST)/share/aclocal-[0-9]*