summaryrefslogtreecommitdiffstats
path: root/tools/automake
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-25 00:27:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-25 00:27:32 +0000
commit2112af299f2b1d2f6e17845d99a0cd9807e03e38 (patch)
treeead7a055a867a7e644a80caea792528443f3208b /tools/automake
parent34cf8e94c2dc66a7ba2bc4c0e74c096965c450dd (diff)
downloadmaster-31e0f0ae-2112af299f2b1d2f6e17845d99a0cd9807e03e38.tar.gz
master-31e0f0ae-2112af299f2b1d2f6e17845d99a0cd9807e03e38.tar.bz2
master-31e0f0ae-2112af299f2b1d2f6e17845d99a0cd9807e03e38.zip
add automake to tools/
SVN-Revision: 9901
Diffstat (limited to 'tools/automake')
-rw-r--r--tools/automake/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/tools/automake/Makefile b/tools/automake/Makefile
new file mode 100644
index 0000000000..cf39cbda8b
--- /dev/null
+++ b/tools/automake/Makefile
@@ -0,0 +1,38 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=automake
+PKG_VERSION:=1.9.6
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@GNU/automake
+PKG_MD5SUM:=c11b8100bb311492d8220378fd8bf9e0
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Build/Configure
+ $(call Build/Configure/Default,\
+ --datarootdir=$(STAGING_DIR_HOST)/share \
+ )
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Build/Install
+ $(MAKE) -C $(PKG_BUILD_DIR) install
+endef
+
+define Build/Clean
+ $(MAKE) -C $(PKG_BUILD_DIR) uninstall
+ $(MAKE) -C $(PKG_BUILD_DIR) clean
+ $(call Build/Clean/Default)
+endef
+
+$(eval $(call HostBuild))