summaryrefslogtreecommitdiffstats
path: root/tools/automake
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-10 16:03:27 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-10 16:03:27 +0000
commit127c395a0eb99d4d84bdc87c205ed7fd63dd5336 (patch)
treef95a5d7166f50088119a40f392859a5352b6cae3 /tools/automake
parent94c3f4ab4d6d9ac9f2647997d4e2759c13131c02 (diff)
downloadmaster-31e0f0ae-127c395a0eb99d4d84bdc87c205ed7fd63dd5336.tar.gz
master-31e0f0ae-127c395a0eb99d4d84bdc87c205ed7fd63dd5336.tar.bz2
master-31e0f0ae-127c395a0eb99d4d84bdc87c205ed7fd63dd5336.zip
automake: use symlinks instead of hardlinks to link aclocal versions
SVN-Revision: 24425
Diffstat (limited to 'tools/automake')
-rw-r--r--tools/automake/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/tools/automake/Makefile b/tools/automake/Makefile
index 932d3ee847..ee7966aeeb 100644
--- a/tools/automake/Makefile
+++ b/tools/automake/Makefile
@@ -29,10 +29,10 @@ define Host/Install
$(MAKE) -C $(HOST_BUILD_DIR) install
mv $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal.real
$(INSTALL_BIN) ./files/aclocal $(STAGING_DIR_HOST)/bin
- ln -f $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.9
- ln -f $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.10
- ln -f $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11
- ln -f $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11.1
+ ln -sf $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.9
+ ln -sf $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.10
+ ln -sf $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11
+ ln -sf $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11.1
endef
define Host/Clean