summaryrefslogtreecommitdiffstats
path: root/tools/automake/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-09 14:51:23 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-09 14:51:23 +0000
commitcdaf75b641e6f55ed8de286d1db81d0338add315 (patch)
treec555970f33f6a52a4e25df595f8d7cb75c9dd8c8 /tools/automake/Makefile
parentda9782f93591fc4856d9fed753a9ee0e3168ede8 (diff)
downloadmaster-31e0f0ae-cdaf75b641e6f55ed8de286d1db81d0338add315.tar.gz
master-31e0f0ae-cdaf75b641e6f55ed8de286d1db81d0338add315.tar.bz2
master-31e0f0ae-cdaf75b641e6f55ed8de286d1db81d0338add315.zip
tools: automake: update to v1.15
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 43895
Diffstat (limited to 'tools/automake/Makefile')
-rw-r--r--tools/automake/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/tools/automake/Makefile b/tools/automake/Makefile
index 546f9b2661..300bee21ea 100644
--- a/tools/automake/Makefile
+++ b/tools/automake/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2013 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,11 +7,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=automake
-PKG_VERSION:=1.11.6
+PKG_VERSION:=1.15
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/automake
-PKG_MD5SUM:=cf4752287ad708f83bd3689da57a32c9
+PKG_MD5SUM:=9a1ddb0e053474d9d1105cfe39b0c48d
include $(INCLUDE_DIR)/host-build.mk
@@ -19,6 +19,9 @@ HOST_CONFIGURE_ARGS += --datarootdir=$(STAGING_DIR_HOST)/share
HOST_CONFIGURE_VARS += am_cv_prog_PERL_ithreads=no
define Host/Install
+ # remove old automake resources to avoid version conflicts
+ rm -rf $(STAGING_DIR_HOST)/share/aclocal-[0-9]*
+ rm -rf $(STAGING_DIR_HOST)/share/automake-[0-9]*
$(MAKE) -C $(HOST_BUILD_DIR) install
mv $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal.real
$(INSTALL_BIN) ./files/aclocal $(STAGING_DIR_HOST)/bin
@@ -26,6 +29,7 @@ define Host/Install
ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.10
ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11
ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11.6
+ ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.15
endef
define Host/Clean