summaryrefslogtreecommitdiffstats
path: root/tools/autoconf
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-22 04:37:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-22 04:37:20 +0000
commit7eb15898755be46e94078faffdacd8c9b0ce66cd (patch)
tree89dc171f7b7c646be5a38ca7d7b99e1be24fa61f /tools/autoconf
parent6ccc1c8e3c9ad0ac95c728573c300264943d8338 (diff)
downloadmaster-31e0f0ae-7eb15898755be46e94078faffdacd8c9b0ce66cd.tar.gz
master-31e0f0ae-7eb15898755be46e94078faffdacd8c9b0ce66cd.tar.bz2
master-31e0f0ae-7eb15898755be46e94078faffdacd8c9b0ce66cd.zip
build system refactoring in preparation for allowing packages to do host-build steps
SVN-Revision: 14610
Diffstat (limited to 'tools/autoconf')
-rw-r--r--tools/autoconf/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/tools/autoconf/Makefile b/tools/autoconf/Makefile
index 30ca2d28d1..12bbaba255 100644
--- a/tools/autoconf/Makefile
+++ b/tools/autoconf/Makefile
@@ -15,23 +15,23 @@ PKG_MD5SUM:=e1fb8fe0b22e651240afdfa2be537a3c
include $(INCLUDE_DIR)/host-build.mk
-define Build/Configure
- $(call Build/Configure/Default,\
+define Host/Configure
+ $(call Host/Configure/Default,\
--datarootdir=$(STAGING_DIR_HOST)/share \
)
endef
-define Build/Compile
- export SHELL="$(BASH)"; $(MAKE) -C $(PKG_BUILD_DIR)
+define Host/Compile
+ export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR)
endef
-define Build/Install
- export SHELL="$(BASH)"; $(MAKE) -C $(PKG_BUILD_DIR) install
+define Host/Install
+ export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) install
endef
-define Build/Clean
- export SHELL="$(BASH)"; $(MAKE) -C $(PKG_BUILD_DIR) uninstall
- $(call Build/Clean/Default)
+define Host/Clean
+ export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
endef
$(eval $(call HostBuild))