summaryrefslogtreecommitdiffstats
path: root/tools/autoconf
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-08 15:59:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-08 15:59:08 +0000
commit480864baef678b7419b01a6e377b7871e67bb1e7 (patch)
tree8aef634195cd15422dc8a4fbb1057f5d3cebedfc /tools/autoconf
parent90904e3704f5adf32269c3a75eb80ca3df1a5422 (diff)
downloadmaster-31e0f0ae-480864baef678b7419b01a6e377b7871e67bb1e7.tar.gz
master-31e0f0ae-480864baef678b7419b01a6e377b7871e67bb1e7.tar.bz2
master-31e0f0ae-480864baef678b7419b01a6e377b7871e67bb1e7.zip
fix autoconf compilation (#3956)
SVN-Revision: 12554
Diffstat (limited to 'tools/autoconf')
-rw-r--r--tools/autoconf/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/tools/autoconf/Makefile b/tools/autoconf/Makefile
index cf66563ea0..30ca2d28d1 100644
--- a/tools/autoconf/Makefile
+++ b/tools/autoconf/Makefile
@@ -22,16 +22,15 @@ define Build/Configure
endef
define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR)
+ export SHELL="$(BASH)"; $(MAKE) -C $(PKG_BUILD_DIR)
endef
define Build/Install
- $(MAKE) -C $(PKG_BUILD_DIR) install
+ export SHELL="$(BASH)"; $(MAKE) -C $(PKG_BUILD_DIR) install
endef
define Build/Clean
- $(MAKE) -C $(PKG_BUILD_DIR) uninstall
- $(MAKE) -C $(PKG_BUILD_DIR) clean
+ export SHELL="$(BASH)"; $(MAKE) -C $(PKG_BUILD_DIR) uninstall
$(call Build/Clean/Default)
endef