summaryrefslogtreecommitdiffstats
path: root/tools/autoconf
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-08-27 20:18:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-08-27 20:18:53 +0000
commit0e00c749461c27fb1e849025a542d16f48528fe7 (patch)
treeadb3fae08ed367e1814b84c559c329deea24a42f /tools/autoconf
parentd42892ab5ec97cc2167f9f560786bceca1409622 (diff)
downloadmaster-31e0f0ae-0e00c749461c27fb1e849025a542d16f48528fe7.tar.gz
master-31e0f0ae-0e00c749461c27fb1e849025a542d16f48528fe7.tar.bz2
master-31e0f0ae-0e00c749461c27fb1e849025a542d16f48528fe7.zip
add autoconf (fixes opkg build issues)
SVN-Revision: 12410
Diffstat (limited to 'tools/autoconf')
-rw-r--r--tools/autoconf/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/tools/autoconf/Makefile b/tools/autoconf/Makefile
new file mode 100644
index 0000000000..cf66563ea0
--- /dev/null
+++ b/tools/autoconf/Makefile
@@ -0,0 +1,38 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=autoconf
+PKG_VERSION:=2.62
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@GNU/autoconf
+PKG_MD5SUM:=e1fb8fe0b22e651240afdfa2be537a3c
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Build/Configure
+ $(call Build/Configure/Default,\
+ --datarootdir=$(STAGING_DIR_HOST)/share \
+ )
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Build/Install
+ $(MAKE) -C $(PKG_BUILD_DIR) install
+endef
+
+define Build/Clean
+ $(MAKE) -C $(PKG_BUILD_DIR) uninstall
+ $(MAKE) -C $(PKG_BUILD_DIR) clean
+ $(call Build/Clean/Default)
+endef
+
+$(eval $(call HostBuild))