summaryrefslogtreecommitdiffstats
path: root/tools/autoconf/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-03-24 13:12:52 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-03-24 13:12:52 +0000
commite0c8e20f8c0765f58707439057405d0eb946746c (patch)
tree104309f45f01d5ac25351cd3b4750165c22fb2aa /tools/autoconf/Makefile
parent8fdd0fb07c3f6bbe55d0a3ef49153e15a3538c7b (diff)
downloadmaster-31e0f0ae-e0c8e20f8c0765f58707439057405d0eb946746c.tar.gz
master-31e0f0ae-e0c8e20f8c0765f58707439057405d0eb946746c.tar.bz2
master-31e0f0ae-e0c8e20f8c0765f58707439057405d0eb946746c.zip
autoconf: portability fixes
The rework of the host tools discovery caused autoconf to embed absolute paths to staging_dir/host/bin/perl into the shebang of the generated autoconfig executables. Switch to the portable "/usr/bin/env perl" and enable global warnings through "$^W" instead of the "-w" interpreter argument. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44971
Diffstat (limited to 'tools/autoconf/Makefile')
-rw-r--r--tools/autoconf/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/tools/autoconf/Makefile b/tools/autoconf/Makefile
index ec154e4647..c45855c03d 100644
--- a/tools/autoconf/Makefile
+++ b/tools/autoconf/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2014 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -15,11 +15,11 @@ PKG_MD5SUM:=50f97f4159805e374639a73e2636f22e
include $(INCLUDE_DIR)/host-build.mk
-define Host/Configure
- $(call Host/Configure/Default,\
- --datarootdir=$(STAGING_DIR_HOST)/share \
- )
-endef
+HOST_CONFIGURE_ARGS += \
+ --datarootdir=$(STAGING_DIR_HOST)/share
+
+HOST_CONFIGURE_VARS += \
+ PERL="/usr/bin/env perl"
define Host/Compile
export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR)