summaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-09-11 23:13:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-09-11 23:13:29 +0000
commite2864e9990e2bbc511e7f767ac7c264530471aa9 (patch)
tree8dc7467668853444726e5cc69d124c9c70d09672 /tools/Makefile
parent8d699086c35a407c372514dda17058dc325d3977 (diff)
downloadmaster-31e0f0ae-e2864e9990e2bbc511e7f767ac7c264530471aa9.tar.gz
master-31e0f0ae-e2864e9990e2bbc511e7f767ac7c264530471aa9.tar.bz2
master-31e0f0ae-e2864e9990e2bbc511e7f767ac7c264530471aa9.zip
tools: install a fake empty ldconfig script to prevent the system ldconfig from messing around with the toolchain (fixes disappearing musl symlink issue)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 42480
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 4a30c8c539..09a0c8cebc 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -133,6 +133,10 @@ $(STAGING_DIR_HOST)/bin/stat: $(STAGING_DIR)/.prepared
false; \
fi
+$(STAGING_DIR_HOST)/bin/ldconfig:
+ touch $@
+ chmod +x $@
+
$(eval $(call PrepareCommand,md5sum,gmd5sum md5sum $(SCRIPT_DIR)/md5sum))
$(eval $(call PrepareCommand,cp,gcp cp))
$(eval $(call PrepareCommand,seq,gseq seq))
@@ -143,7 +147,7 @@ $(eval $(call PrepareCommand,grep,ggrep grep))
$(eval $(call PrepareCommand,tar,gtar tar))
$(eval $(call PrepareCommand,diff,gdiff diff))
-$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,md5sum cp stat seq python awk getopt grep tar diff)
+$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,md5sum cp stat seq python awk getopt grep tar diff ldconfig)
$(curdir)//prepare = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared $($(curdir)/cmddeps)
$(curdir)//compile = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared $($(curdir)/cmddeps)