summaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-09-11 18:38:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-09-11 18:38:02 +0000
commitcaddbf5431dbed6d1acc574a9a411e94a5824845 (patch)
tree7c8e275219d705ba67243552de3f3d49d7863c3f /tools/Makefile
parentaccc5e369343b9389081dc7ede7197e55d52d74f (diff)
downloadmaster-31e0f0ae-caddbf5431dbed6d1acc574a9a411e94a5824845.tar.gz
master-31e0f0ae-caddbf5431dbed6d1acc574a9a411e94a5824845.tar.bz2
master-31e0f0ae-caddbf5431dbed6d1acc574a9a411e94a5824845.zip
tools: add tar host build, required for --sort=name which was only added in the latest version
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 46876
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 60041ddc31..dda429f935 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -81,6 +81,9 @@ endif
# dependency for tools which have patches directory
$(foreach tool, $(tools-y), $(if $(wildcard $(curdir)/$(tool)/patches),$(eval $(curdir)/$(tool)/compile += $(curdir)/patch/install)))
+$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/tar/install))
+tools-y += tar
+
$(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
$(curdir)/builddirs-default := $(tools-y)