summaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-07-20 10:50:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-07-20 10:50:46 +0000
commit9402cb747ef51c43046b7159061afb50a4302f3b (patch)
tree2a06dc572b815704d2fe2ab22b1a986dfd34df97 /tools/Makefile
parent38dbf49b61c56aee551bf425e8e47e7cfa12be36 (diff)
downloadmaster-31e0f0ae-9402cb747ef51c43046b7159061afb50a4302f3b.tar.gz
master-31e0f0ae-9402cb747ef51c43046b7159061afb50a4302f3b.tar.bz2
master-31e0f0ae-9402cb747ef51c43046b7159061afb50a4302f3b.zip
tools: drop circular dependency between patch and ccache, build patch without ccache (fixes #20132)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 46434
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 8b5dd6c520..60041ddc31 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -73,7 +73,7 @@ $(curdir)/gengetopt/compile := $(curdir)/libtool/install
$(curdir)/patchelf/compile := $(curdir)/libtool/install
ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
-$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))
+$(foreach tool, $(filter-out patch,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))
tools-y += ccache
endif