summaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-08-23 10:58:34 +0200
committerFelix Fietkau <nbd@nbd.name>2016-08-23 11:56:13 +0200
commit88b16da8c48231058682b5c0348c8e8eb0468c0c (patch)
treeff070a109ff2d1a1b79d8526051f9ce9e973224b /tools/Makefile
parent4170267f5a794eb3fa6bb1718a665e3395077434 (diff)
downloadmaster-31e0f0ae-88b16da8c48231058682b5c0348c8e8eb0468c0c.tar.gz
master-31e0f0ae-88b16da8c48231058682b5c0348c8e8eb0468c0c.tar.bz2
master-31e0f0ae-88b16da8c48231058682b5c0348c8e8eb0468c0c.zip
tools: build GNU date from coreutils on non-Linux systems
Required for reproducible builds in the kernel build system Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/Makefile b/tools/Makefile
index abf5b043eb..f7a731619b 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -84,6 +84,9 @@ tools-y += libressl
$(curdir)/mkimage/compile += $(curdir)/libressl/install
$(curdir)/firmware-utils/compile += $(curdir)/libressl/install
endif
+ifneq ($(HOST_OS),Linux)
+ tools-y += coreutils
+endif
ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
$(foreach tool, $(filter-out patch,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))