summaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-10 15:48:32 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-10 15:48:32 +0000
commit572b94308008ea0323cb11df945ad7c2313fc320 (patch)
treecf680a8e8630c5d8515b0019281ee9b08f112ebb /tools/Makefile
parenta2fcaa77fc02d8a3c64afe33b7002de677273d5a (diff)
downloadmaster-31e0f0ae-572b94308008ea0323cb11df945ad7c2313fc320.tar.gz
master-31e0f0ae-572b94308008ea0323cb11df945ad7c2313fc320.tar.bz2
master-31e0f0ae-572b94308008ea0323cb11df945ad7c2313fc320.zip
tools: add patchelf host build
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44376
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index b4938d3a08..93aa5b3e6c 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -28,7 +28,7 @@ tools-y += m4 libtool autoconf automake flex bison pkg-config sed mklibs
tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
tools-y += firmware-utils patch-image patch quilt yaffs2 flock padjffs2
tools-y += mm-macros xorg-macros xfce-macros missing-macros xz cmake scons bc
-tools-y += findutils gengetopt
+tools-y += findutils gengetopt patchelf
tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
tools-$(CONFIG_powerpc) += upx
tools-$(CONFIG_TARGET_x86) += qemu
@@ -74,6 +74,7 @@ $(curdir)/cloog/compile := $(curdir)/ppl/install
$(curdir)/bc/compile := $(curdir)/bison/install
$(curdir)/findutils/compile := $(curdir)/bison/install
$(curdir)/gengetopt/compile := $(curdir)/libtool/install
+$(curdir)/patchelf/compile := $(curdir)/libtool/install
ifneq ($(CONFIG_CCACHE),)
$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))