summaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-18 18:07:53 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-18 18:07:53 +0000
commit51538948fec438915933adcd110653e1ddb32910 (patch)
treea698403515eec984b0b1559a8d665fc2d1edb14f /tools/Makefile
parentb40d260aaf6c6cd4dab390094a706dfa409e9012 (diff)
downloadmaster-31e0f0ae-51538948fec438915933adcd110653e1ddb32910.tar.gz
master-31e0f0ae-51538948fec438915933adcd110653e1ddb32910.tar.bz2
master-31e0f0ae-51538948fec438915933adcd110653e1ddb32910.zip
make libtool a tool build and let autoconf depend on it
SVN-Revision: 24673
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 81a6e5c8f0..3e76b70bc8 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -14,7 +14,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5) += gmp mpfr
tools-$(CONFIG_GCC_VERSION_4_5) += mpc libelf
endif
-tools-y += m4 autoconf automake flex bison pkg-config sed mklibs
+tools-y += m4 libtool autoconf automake flex bison pkg-config sed mklibs
tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
tools-y += firmware-utils patch-cmdline quilt yaffs2 flock
tools-y += xorg-macros xz
@@ -36,11 +36,12 @@ endif
# builddir dependencies
$(curdir)/bison/compile := $(curdir)/flex/install
$(curdir)/pkg-config/compile := $(curdir)/sed/install
+$(curdir)/libtool/compile := $(curdir)/sed/install
$(curdir)/squashfs/compile := $(curdir)/lzma-old/install
$(curdir)/squashfs4/compile := $(curdir)/lzma/install
$(curdir)/quilt/compile := $(curdir)/sed/install $(curdir)/autoconf/install
$(curdir)/dtc/compile := $(curdir)/bison/install
-$(curdir)/autoconf/compile := $(curdir)/m4/install
+$(curdir)/autoconf/compile := $(curdir)/m4/install $(curdir)/libtool/install
$(curdir)/automake/compile := $(curdir)/m4/install $(curdir)/autoconf/install $(curdir)/pkg-config/install
$(curdir)/mpc/compile := $(curdir)/gmp/install
$(curdir)/mpfr/compile := $(curdir)/gmp/install