summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorSyrone Wong <wong.syrone@gmail.com>2016-09-03 18:31:14 +0800
committerFelix Fietkau <nbd@nbd.name>2016-09-04 13:36:09 +0200
commitf8c7e935ef8060b8ab2f5ca52832ef8dfea361bc (patch)
tree7f0a398d55e7d4b181a392bffae21e0a46210c78 /toolchain
parentaa53f78038d541052de8764323f6f26578327606 (diff)
downloadmaster-31e0f0ae-f8c7e935ef8060b8ab2f5ca52832ef8dfea361bc.tar.gz
master-31e0f0ae-f8c7e935ef8060b8ab2f5ca52832ef8dfea361bc.tar.bz2
master-31e0f0ae-f8c7e935ef8060b8ab2f5ca52832ef8dfea361bc.zip
toolchain/gcc: bump GCC 6.1.0 to 6.2.0
Compile and run tested on ar71xx and mvebu Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Config.version2
-rw-r--r--toolchain/gcc/common.mk4
-rw-r--r--toolchain/gcc/patches/6.2.0/001-revert_register_mode_search.patch (renamed from toolchain/gcc/patches/6.1.0/001-revert_register_mode_search.patch)0
-rw-r--r--toolchain/gcc/patches/6.2.0/002-case_insensitive.patch (renamed from toolchain/gcc/patches/6.1.0/002-case_insensitive.patch)0
-rw-r--r--toolchain/gcc/patches/6.2.0/010-documentation.patch (renamed from toolchain/gcc/patches/6.1.0/010-documentation.patch)0
-rw-r--r--toolchain/gcc/patches/6.2.0/100-uclibc-conf.patch (renamed from toolchain/gcc/patches/6.1.0/100-uclibc-conf.patch)0
-rw-r--r--toolchain/gcc/patches/6.2.0/230-musl_libssp.patch (renamed from toolchain/gcc/patches/6.1.0/230-musl_libssp.patch)0
-rw-r--r--toolchain/gcc/patches/6.2.0/300-mips_Os_cpu_rtx_cost_model.patch (renamed from toolchain/gcc/patches/6.1.0/300-mips_Os_cpu_rtx_cost_model.patch)0
-rw-r--r--toolchain/gcc/patches/6.2.0/800-arm_v5te_no_ldrd_strd.patch (renamed from toolchain/gcc/patches/6.1.0/800-arm_v5te_no_ldrd_strd.patch)0
-rw-r--r--toolchain/gcc/patches/6.2.0/810-arm-softfloat-libgcc.patch (renamed from toolchain/gcc/patches/6.1.0/810-arm-softfloat-libgcc.patch)0
-rw-r--r--toolchain/gcc/patches/6.2.0/820-libgcc_pic.patch (renamed from toolchain/gcc/patches/6.1.0/820-libgcc_pic.patch)0
-rw-r--r--toolchain/gcc/patches/6.2.0/830-arm_unbreak_armv4t.patch (renamed from toolchain/gcc/patches/6.1.0/830-arm_unbreak_armv4t.patch)0
-rw-r--r--toolchain/gcc/patches/6.2.0/840-armv4_pass_fix-v4bx_to_ld.patch (renamed from toolchain/gcc/patches/6.1.0/840-armv4_pass_fix-v4bx_to_ld.patch)0
-rw-r--r--toolchain/gcc/patches/6.2.0/850-use_shared_libgcc.patch (renamed from toolchain/gcc/patches/6.1.0/850-use_shared_libgcc.patch)0
-rw-r--r--toolchain/gcc/patches/6.2.0/851-libgcc_no_compat.patch (renamed from toolchain/gcc/patches/6.1.0/851-libgcc_no_compat.patch)0
-rw-r--r--toolchain/gcc/patches/6.2.0/870-ppc_no_crtsavres.patch (renamed from toolchain/gcc/patches/6.1.0/870-ppc_no_crtsavres.patch)2
-rw-r--r--toolchain/gcc/patches/6.2.0/880-no_java_section.patch (renamed from toolchain/gcc/patches/6.1.0/880-no_java_section.patch)0
-rw-r--r--toolchain/gcc/patches/6.2.0/900-bad-mips16-crt.patch (renamed from toolchain/gcc/patches/6.1.0/900-bad-mips16-crt.patch)0
-rw-r--r--toolchain/gcc/patches/6.2.0/910-mbsd_multi.patch (renamed from toolchain/gcc/patches/6.1.0/910-mbsd_multi.patch)4
-rw-r--r--toolchain/gcc/patches/6.2.0/920-specs_nonfatal_getenv.patch (renamed from toolchain/gcc/patches/6.1.0/920-specs_nonfatal_getenv.patch)2
-rw-r--r--toolchain/gcc/patches/6.2.0/930-fix-mips-noexecstack.patch (renamed from toolchain/gcc/patches/6.1.0/930-fix-mips-noexecstack.patch)0
-rw-r--r--toolchain/gcc/patches/6.2.0/940-no-clobber-stamp-bits.patch (renamed from toolchain/gcc/patches/6.1.0/940-no-clobber-stamp-bits.patch)0
-rw-r--r--toolchain/gcc/patches/6.2.0/950-cpp_file_path_translation.patch (renamed from toolchain/gcc/patches/6.1.0/950-cpp_file_path_translation.patch)2
23 files changed, 8 insertions, 8 deletions
diff --git a/toolchain/gcc/Config.version b/toolchain/gcc/Config.version
index 53caa24577..27aa20cb39 100644
--- a/toolchain/gcc/Config.version
+++ b/toolchain/gcc/Config.version
@@ -5,7 +5,7 @@ config GCC_VERSION_4_8_ARC
config GCC_VERSION
string
default "arc-2016.03" if GCC_VERSION_4_8_ARC
- default "6.1.0" if GCC_USE_VERSION_6
+ default "6.2.0" if GCC_USE_VERSION_6
default "5.4.0"
config GCC_VERSION_4_8
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 4220cf54f3..c6949dc7b4 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -32,8 +32,8 @@ ifeq ($(PKG_VERSION),5.4.0)
PKG_MD5SUM:=4c626ac2a83ef30dfb9260e6f59c2b30
endif
-ifeq ($(PKG_VERSION),6.1.0)
- PKG_MD5SUM:=8fb6cb98b8459f5863328380fbf06bd1
+ifeq ($(PKG_VERSION),6.2.0)
+ PKG_MD5SUM:=9768625159663b300ae4de2f4745fcc4
endif
ifneq ($(CONFIG_GCC_VERSION_4_8_ARC),)
diff --git a/toolchain/gcc/patches/6.1.0/001-revert_register_mode_search.patch b/toolchain/gcc/patches/6.2.0/001-revert_register_mode_search.patch
index bd6fbdb4a9..bd6fbdb4a9 100644
--- a/toolchain/gcc/patches/6.1.0/001-revert_register_mode_search.patch
+++ b/toolchain/gcc/patches/6.2.0/001-revert_register_mode_search.patch
diff --git a/toolchain/gcc/patches/6.1.0/002-case_insensitive.patch b/toolchain/gcc/patches/6.2.0/002-case_insensitive.patch
index b3d2dbe291..b3d2dbe291 100644
--- a/toolchain/gcc/patches/6.1.0/002-case_insensitive.patch
+++ b/toolchain/gcc/patches/6.2.0/002-case_insensitive.patch
diff --git a/toolchain/gcc/patches/6.1.0/010-documentation.patch b/toolchain/gcc/patches/6.2.0/010-documentation.patch
index 2adb28c83d..2adb28c83d 100644
--- a/toolchain/gcc/patches/6.1.0/010-documentation.patch
+++ b/toolchain/gcc/patches/6.2.0/010-documentation.patch
diff --git a/toolchain/gcc/patches/6.1.0/100-uclibc-conf.patch b/toolchain/gcc/patches/6.2.0/100-uclibc-conf.patch
index ff9ad94f62..ff9ad94f62 100644
--- a/toolchain/gcc/patches/6.1.0/100-uclibc-conf.patch
+++ b/toolchain/gcc/patches/6.2.0/100-uclibc-conf.patch
diff --git a/toolchain/gcc/patches/6.1.0/230-musl_libssp.patch b/toolchain/gcc/patches/6.2.0/230-musl_libssp.patch
index 8dfd1fc287..8dfd1fc287 100644
--- a/toolchain/gcc/patches/6.1.0/230-musl_libssp.patch
+++ b/toolchain/gcc/patches/6.2.0/230-musl_libssp.patch
diff --git a/toolchain/gcc/patches/6.1.0/300-mips_Os_cpu_rtx_cost_model.patch b/toolchain/gcc/patches/6.2.0/300-mips_Os_cpu_rtx_cost_model.patch
index d76bd8cb1d..d76bd8cb1d 100644
--- a/toolchain/gcc/patches/6.1.0/300-mips_Os_cpu_rtx_cost_model.patch
+++ b/toolchain/gcc/patches/6.2.0/300-mips_Os_cpu_rtx_cost_model.patch
diff --git a/toolchain/gcc/patches/6.1.0/800-arm_v5te_no_ldrd_strd.patch b/toolchain/gcc/patches/6.2.0/800-arm_v5te_no_ldrd_strd.patch
index 2e7c23f851..2e7c23f851 100644
--- a/toolchain/gcc/patches/6.1.0/800-arm_v5te_no_ldrd_strd.patch
+++ b/toolchain/gcc/patches/6.2.0/800-arm_v5te_no_ldrd_strd.patch
diff --git a/toolchain/gcc/patches/6.1.0/810-arm-softfloat-libgcc.patch b/toolchain/gcc/patches/6.2.0/810-arm-softfloat-libgcc.patch
index 1d06f5b2ec..1d06f5b2ec 100644
--- a/toolchain/gcc/patches/6.1.0/810-arm-softfloat-libgcc.patch
+++ b/toolchain/gcc/patches/6.2.0/810-arm-softfloat-libgcc.patch
diff --git a/toolchain/gcc/patches/6.1.0/820-libgcc_pic.patch b/toolchain/gcc/patches/6.2.0/820-libgcc_pic.patch
index f925d96f66..f925d96f66 100644
--- a/toolchain/gcc/patches/6.1.0/820-libgcc_pic.patch
+++ b/toolchain/gcc/patches/6.2.0/820-libgcc_pic.patch
diff --git a/toolchain/gcc/patches/6.1.0/830-arm_unbreak_armv4t.patch b/toolchain/gcc/patches/6.2.0/830-arm_unbreak_armv4t.patch
index 37f8f2a54d..37f8f2a54d 100644
--- a/toolchain/gcc/patches/6.1.0/830-arm_unbreak_armv4t.patch
+++ b/toolchain/gcc/patches/6.2.0/830-arm_unbreak_armv4t.patch
diff --git a/toolchain/gcc/patches/6.1.0/840-armv4_pass_fix-v4bx_to_ld.patch b/toolchain/gcc/patches/6.2.0/840-armv4_pass_fix-v4bx_to_ld.patch
index cb1fb98235..cb1fb98235 100644
--- a/toolchain/gcc/patches/6.1.0/840-armv4_pass_fix-v4bx_to_ld.patch
+++ b/toolchain/gcc/patches/6.2.0/840-armv4_pass_fix-v4bx_to_ld.patch
diff --git a/toolchain/gcc/patches/6.1.0/850-use_shared_libgcc.patch b/toolchain/gcc/patches/6.2.0/850-use_shared_libgcc.patch
index cd20244c69..cd20244c69 100644
--- a/toolchain/gcc/patches/6.1.0/850-use_shared_libgcc.patch
+++ b/toolchain/gcc/patches/6.2.0/850-use_shared_libgcc.patch
diff --git a/toolchain/gcc/patches/6.1.0/851-libgcc_no_compat.patch b/toolchain/gcc/patches/6.2.0/851-libgcc_no_compat.patch
index 80c3476841..80c3476841 100644
--- a/toolchain/gcc/patches/6.1.0/851-libgcc_no_compat.patch
+++ b/toolchain/gcc/patches/6.2.0/851-libgcc_no_compat.patch
diff --git a/toolchain/gcc/patches/6.1.0/870-ppc_no_crtsavres.patch b/toolchain/gcc/patches/6.2.0/870-ppc_no_crtsavres.patch
index 71671619ee..c1eaf975c3 100644
--- a/toolchain/gcc/patches/6.1.0/870-ppc_no_crtsavres.patch
+++ b/toolchain/gcc/patches/6.2.0/870-ppc_no_crtsavres.patch
@@ -1,6 +1,6 @@
--- a/gcc/config/rs6000/rs6000.c
+++ b/gcc/config/rs6000/rs6000.c
-@@ -23090,7 +23090,7 @@ rs6000_savres_strategy (rs6000_stack_t *
+@@ -24141,7 +24141,7 @@ rs6000_savres_strategy (rs6000_stack_t *
/* Define cutoff for using out-of-line functions to save registers. */
if (DEFAULT_ABI == ABI_V4 || TARGET_ELF)
{
diff --git a/toolchain/gcc/patches/6.1.0/880-no_java_section.patch b/toolchain/gcc/patches/6.2.0/880-no_java_section.patch
index 0fa9e627c2..0fa9e627c2 100644
--- a/toolchain/gcc/patches/6.1.0/880-no_java_section.patch
+++ b/toolchain/gcc/patches/6.2.0/880-no_java_section.patch
diff --git a/toolchain/gcc/patches/6.1.0/900-bad-mips16-crt.patch b/toolchain/gcc/patches/6.2.0/900-bad-mips16-crt.patch
index dd6e9dc889..dd6e9dc889 100644
--- a/toolchain/gcc/patches/6.1.0/900-bad-mips16-crt.patch
+++ b/toolchain/gcc/patches/6.2.0/900-bad-mips16-crt.patch
diff --git a/toolchain/gcc/patches/6.1.0/910-mbsd_multi.patch b/toolchain/gcc/patches/6.2.0/910-mbsd_multi.patch
index 0265d68952..62203dfcf6 100644
--- a/toolchain/gcc/patches/6.1.0/910-mbsd_multi.patch
+++ b/toolchain/gcc/patches/6.2.0/910-mbsd_multi.patch
@@ -178,7 +178,7 @@
-Wno-format-contains-nul -Wno-format-extra-args -Wformat-nonliteral @gol
-Wformat-security -Wformat-signedness -Wformat-y2k -Wframe-address @gol
-Wframe-larger-than=@var{len} -Wno-free-nonheap-object -Wjump-misses-init @gol
-@@ -5736,6 +5736,22 @@ This option is only supported for C and
+@@ -5737,6 +5737,22 @@ This option is only supported for C and
@option{-Wall} and by @option{-Wpedantic}, which can be disabled with
@option{-Wno-pointer-sign}.
@@ -201,7 +201,7 @@
@item -Wstack-protector
@opindex Wstack-protector
@opindex Wno-stack-protector
-@@ -6604,7 +6620,7 @@ so, the first branch is redirected to ei
+@@ -6605,7 +6621,7 @@ so, the first branch is redirected to ei
second branch or a point immediately following it, depending on whether
the condition is known to be true or false.
diff --git a/toolchain/gcc/patches/6.1.0/920-specs_nonfatal_getenv.patch b/toolchain/gcc/patches/6.2.0/920-specs_nonfatal_getenv.patch
index 6d9672e506..dc0acb95a8 100644
--- a/toolchain/gcc/patches/6.1.0/920-specs_nonfatal_getenv.patch
+++ b/toolchain/gcc/patches/6.2.0/920-specs_nonfatal_getenv.patch
@@ -1,6 +1,6 @@
--- a/gcc/gcc.c
+++ b/gcc/gcc.c
-@@ -9194,8 +9194,10 @@ getenv_spec_function (int argc, const ch
+@@ -9198,8 +9198,10 @@ getenv_spec_function (int argc, const ch
value = varname;
if (!value)
diff --git a/toolchain/gcc/patches/6.1.0/930-fix-mips-noexecstack.patch b/toolchain/gcc/patches/6.2.0/930-fix-mips-noexecstack.patch
index 2a99840b63..2a99840b63 100644
--- a/toolchain/gcc/patches/6.1.0/930-fix-mips-noexecstack.patch
+++ b/toolchain/gcc/patches/6.2.0/930-fix-mips-noexecstack.patch
diff --git a/toolchain/gcc/patches/6.1.0/940-no-clobber-stamp-bits.patch b/toolchain/gcc/patches/6.2.0/940-no-clobber-stamp-bits.patch
index 65f59fcfa7..65f59fcfa7 100644
--- a/toolchain/gcc/patches/6.1.0/940-no-clobber-stamp-bits.patch
+++ b/toolchain/gcc/patches/6.2.0/940-no-clobber-stamp-bits.patch
diff --git a/toolchain/gcc/patches/6.1.0/950-cpp_file_path_translation.patch b/toolchain/gcc/patches/6.2.0/950-cpp_file_path_translation.patch
index 5b0d6ccacf..d467eb7c9a 100644
--- a/toolchain/gcc/patches/6.1.0/950-cpp_file_path_translation.patch
+++ b/toolchain/gcc/patches/6.2.0/950-cpp_file_path_translation.patch
@@ -64,7 +64,7 @@ Forward ported from attachment to https://gcc.gnu.org/bugzilla/show_bug.cgi?id=4
@item Code Generation Options
@xref{Code Gen Options,,Options for Code Generation Conventions}.
-@@ -10860,6 +10860,12 @@ be searched for header files only for th
+@@ -10861,6 +10861,12 @@ be searched for header files only for th
"@var{file}"}; they are not searched for @code{#include <@var{file}>},
otherwise just like @option{-I}.