summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorStefan Weil <sw@weilnetz.de>2009-08-03 10:54:04 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-25 10:39:27 +0200
commitd0619fb02ce1464ccc0aa75ebf28c3b2e1c5e11e (patch)
tree5773ede2f1c601b489ecfd8b6094301d783d11a4 /toolchain
parent3f506bdbb08c0062cbbeac3c9409e479293493d3 (diff)
downloadmaster-31e0f0ae-d0619fb02ce1464ccc0aa75ebf28c3b2e1c5e11e.tar.gz
master-31e0f0ae-d0619fb02ce1464ccc0aa75ebf28c3b2e1c5e11e.tar.bz2
master-31e0f0ae-d0619fb02ce1464ccc0aa75ebf28c3b2e1c5e11e.zip
Remove existing old link before creating a new one
This is needed after a kernel update, otherwise the new link is written as linux/linux-$(LINUX_VERSION). Signed-off-by: Stefan Weil <sw@weilnetz.de>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/kernel-headers/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/toolchain/kernel-headers/Makefile b/toolchain/kernel-headers/Makefile
index 68c83a065e..fa7d349baa 100644
--- a/toolchain/kernel-headers/Makefile
+++ b/toolchain/kernel-headers/Makefile
@@ -72,7 +72,8 @@ endef
define Host/Prepare
$(call Kernel/Prepare/Default)
- ln -sf linux-$(LINUX_VERSION) $(BUILD_DIR_TOOLCHAIN)/linux
+ rm -f $(BUILD_DIR_TOOLCHAIN)/linux
+ ln -s linux-$(LINUX_VERSION) $(BUILD_DIR_TOOLCHAIN)/linux
$(SED) 's/@expr length/@-expr length/' $(HOST_BUILD_DIR)/Makefile
endef