summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorDirk Neukirchen <dirkneukirchen@web.de>2016-08-29 14:16:14 +0200
committerFelix Fietkau <nbd@nbd.name>2016-08-30 10:51:21 +0200
commitbf604f35035ae49a3db8a1e1ff67f512a0de86bd (patch)
tree1389c76d2f4f3e8acd5a3e1f3694493cd69128e3 /toolchain
parent98206cb9c62a86f3e72b74a71e9ed836bac1fc71 (diff)
downloadmaster-31e0f0ae-bf604f35035ae49a3db8a1e1ff67f512a0de86bd.tar.gz
master-31e0f0ae-bf604f35035ae49a3db8a1e1ff67f512a0de86bd.tar.bz2
master-31e0f0ae-bf604f35035ae49a3db8a1e1ff67f512a0de86bd.zip
glibc: add 2.24
since eglibc is deprecated just use glibc as name - fix build errors w. stack-protector (observed for x86_64): libresolv_pic.a(gethnamaddr.os): In function `addrsort': gethnamaddr.c:(.text+0x425): undefined reference to `__stack_chk_guard' by additionally setting libc_cv_ssp_strong=no like previously libc_cv_ssp=no was set - fix compile errors on 2.24 x86 introduced by upstream changesets "Optimize i386 syscall inlining" errors are like: - https://sourceware.org/ml/libc-alpha/2015-10/msg00745.html and trying to fix with the whats suggested at: https://patchwork.openembedded.org/patch/118909/ leads to other error: gcc6: elf/librtld.os: In function `__mmap': (.text+0x131a9): undefined reference to `__libc_do_syscall' or: gcc5: elf/dl-load.os {standard input}: Assembler messages: {standard input}:5129: Error: symbol `__x86.get_pc_thunk.cx' is already defined instead of testing other flags/effects (-fno-omit-frame-pointer) just use -O2 (like buildroot does) instead of -Os boot+pings tested on: qemu malta (le+be) (gcc5+bin2.25.1) qemu aarch64 (gcc5+bin2.25.1) qemu x86_64 (gcc6+bin2.26) qemu x86 generic (gcc6+bin2.26) Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/Config.in2
-rw-r--r--toolchain/glibc/Config.in6
-rw-r--r--toolchain/glibc/Config.version4
-rw-r--r--toolchain/glibc/common.mk10
-rw-r--r--toolchain/glibc/patches/2.24/100-fix_cross_rpcgen.patch52
-rw-r--r--toolchain/glibc/patches/2.24/200-add-dl-search-paths.patch14
6 files changed, 85 insertions, 3 deletions
diff --git a/toolchain/Config.in b/toolchain/Config.in
index 7cc51a1bb1..75dc5361a6 100644
--- a/toolchain/Config.in
+++ b/toolchain/Config.in
@@ -225,7 +225,7 @@ choice
Select the C library implementation.
config LIBC_USE_GLIBC
- bool "Use (e)glibc"
+ bool "Use glibc"
select USE_GLIBC
depends on !arc
diff --git a/toolchain/glibc/Config.in b/toolchain/glibc/Config.in
index b44d1f6818..ef5ef562f4 100644
--- a/toolchain/glibc/Config.in
+++ b/toolchain/glibc/Config.in
@@ -1,5 +1,5 @@
choice
- prompt "(e)glibc version"
+ prompt "glibc version"
depends on TOOLCHAINOPTS && USE_GLIBC
default GLIBC_USE_VERSION_2_22
help
@@ -9,4 +9,8 @@ choice
bool "glibc 2.22"
select GLIBC_VERSION_2_22
+ config GLIBC_USE_VERSION_2_24
+ bool "glibc 2.24"
+ select GLIBC_VERSION_2_24
+
endchoice
diff --git a/toolchain/glibc/Config.version b/toolchain/glibc/Config.version
index 4085f89c5e..ec8280f5dd 100644
--- a/toolchain/glibc/Config.version
+++ b/toolchain/glibc/Config.version
@@ -3,9 +3,13 @@ if USE_GLIBC
config GLIBC_VERSION
string
default "2.22" if GLIBC_VERSION_2_22
+ default "2.24" if GLIBC_VERSION_2_24
config GLIBC_VERSION_2_22
default y if !TOOLCHAINOPTS
bool
+config GLIBC_VERSION_2_24
+ bool
+
endif
diff --git a/toolchain/glibc/common.mk b/toolchain/glibc/common.mk
index 4de9905f34..11de291ab8 100644
--- a/toolchain/glibc/common.mk
+++ b/toolchain/glibc/common.mk
@@ -16,6 +16,9 @@ REVISION_2.21 = 16d0a0c
MD5SUM_2.22 = b575850e77b37d70f96472285290b391
REVISION_2.22 = b995d95
+MD5SUM_2.24 = 5c5a6f1ac6fce866e37643c41ac116f3
+REVISION_2.24 = 8c716c2
+
PKG_NAME:=glibc
PKG_VERSION:=$(call qstrip,$(CONFIG_GLIBC_VERSION))
@@ -55,10 +58,14 @@ ifeq ($(ARCH),mips64)
endif
endif
+
+# -Os miscompiles w. 2.24 gcc5/gcc6
+# only -O2 tested by upstream changeset
+# "Optimize i386 syscall inlining for GCC 5"
GLIBC_CONFIGURE:= \
BUILD_CC="$(HOSTCC)" \
$(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
+ CFLAGS="-O2 $(filter-out -Os,$(call qstrip,$(TARGET_CFLAGS)))" \
libc_cv_slibdir="/lib" \
use_ldconfig=no \
$(HOST_BUILD_DIR)/$(GLIBC_PATH)configure \
@@ -74,6 +81,7 @@ GLIBC_CONFIGURE:= \
--$(if $(CONFIG_SOFT_FLOAT),without,with)-fp
export libc_cv_ssp=no
+export libc_cv_ssp_strong=no
export ac_cv_header_cpuid_h=yes
export HOST_CFLAGS := $(HOST_CFLAGS) -idirafter $(CURDIR)/$(PATH_PREFIX)/include
diff --git a/toolchain/glibc/patches/2.24/100-fix_cross_rpcgen.patch b/toolchain/glibc/patches/2.24/100-fix_cross_rpcgen.patch
new file mode 100644
index 0000000000..6a5e537b77
--- /dev/null
+++ b/toolchain/glibc/patches/2.24/100-fix_cross_rpcgen.patch
@@ -0,0 +1,52 @@
+--- a/sunrpc/rpc/types.h
++++ b/sunrpc/rpc/types.h
+@@ -75,18 +75,23 @@ typedef unsigned long rpcport_t;
+ #endif
+
+ #ifndef __u_char_defined
+-typedef __u_char u_char;
+-typedef __u_short u_short;
+-typedef __u_int u_int;
+-typedef __u_long u_long;
+-typedef __quad_t quad_t;
+-typedef __u_quad_t u_quad_t;
+-typedef __fsid_t fsid_t;
++typedef unsigned char u_char;
++typedef unsigned short u_short;
++typedef unsigned int u_int;
++typedef unsigned long u_long;
++#if __WORDSIZE == 64
++typedef long int quad_t;
++typedef unsigned long int u_quad_t;
++#elif defined __GLIBC_HAVE_LONG_LONG
++typedef long long int quad_t;
++typedef unsigned long long int u_quad_t;
++#endif
++typedef u_quad_t fsid_t;
+ # define __u_char_defined
+ #endif
+-#ifndef __daddr_t_defined
+-typedef __daddr_t daddr_t;
+-typedef __caddr_t caddr_t;
++#if !defined(__daddr_t_defined) && defined(linux)
++typedef long int daddr_t;
++typedef char *caddr_t;
+ # define __daddr_t_defined
+ #endif
+
+--- a/sunrpc/rpc_main.c
++++ b/sunrpc/rpc_main.c
+@@ -958,9 +958,10 @@ mkfile_output (struct commandline *cmd)
+ abort ();
+ temp = rindex (cmd->infile, '.');
+ cp = stpcpy (mkfilename, "Makefile.");
+- if (temp != NULL)
+- *((char *) stpncpy (cp, cmd->infile, temp - cmd->infile)) = '\0';
+- else
++ if (temp != NULL) {
++ strncpy(cp, cmd->infile, temp - cmd->infile);
++ cp[temp - cmd->infile - 1] = 0;
++ } else
+ stpcpy (cp, cmd->infile);
+
+ }
diff --git a/toolchain/glibc/patches/2.24/200-add-dl-search-paths.patch b/toolchain/glibc/patches/2.24/200-add-dl-search-paths.patch
new file mode 100644
index 0000000000..d65a0bcdd0
--- /dev/null
+++ b/toolchain/glibc/patches/2.24/200-add-dl-search-paths.patch
@@ -0,0 +1,14 @@
+add /usr/lib to default search path for the dynamic linker
+
+--- a/Makeconfig
++++ b/Makeconfig
+@@ -526,6 +526,9 @@ else
+ default-rpath = $(libdir)
+ endif
+
++# Add /usr/lib to default search path for the dynamic linker
++user-defined-trusted-dirs := /usr/lib
++
+ ifndef link-extra-libs
+ link-extra-libs = $(LDLIBS-$(@F))
+ link-extra-libs-static = $(link-extra-libs)