summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-13 11:35:41 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-13 11:35:41 +0000
commit9d6a9b6f516e650630d94012cb7e898df5301189 (patch)
tree865c32a1cded6d977f20ee8a0934327cb0425930 /toolchain
parent3d41dbae65fb3d5103dd0a7d6178c4990596b3db (diff)
downloadmaster-31e0f0ae-9d6a9b6f516e650630d94012cb7e898df5301189.tar.gz
master-31e0f0ae-9d6a9b6f516e650630d94012cb7e898df5301189.tar.bz2
master-31e0f0ae-9d6a9b6f516e650630d94012cb7e898df5301189.zip
gcc: set the isl/cloog prefix when graphite is enabled, disable it explicitly if it is disabled in the config
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 47465
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/common.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 5214765d6b..0ac7de19f5 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -108,6 +108,16 @@ ifdef CONFIG_USE_UCLIBC
export glibcxx_cv_c99_math_tr1=no
endif
+ifdef CONFIG_GCC_USE_GRAPHITE
+ ifdef CONFIG_GCC_VERSION_4_8
+ GRAPHITE_CONFIGURE=--with-cloog=$(REAL_STAGING_DIR_HOST)
+ else
+ GRAPHITE_CONFIGURE=--with-isl=$(REAL_STAGING_DIR_HOST)
+ endif
+else
+ GRAPHITE_CONFIGURE=--without-isl --without-cloog
+endif
+
GCC_CONFIGURE:= \
SHELL="$(BASH)" \
$(if $(shell gcc --version 2>&1 | grep LLVM), \