summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-09-21 17:40:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-09-21 17:40:44 +0000
commit8f57c55993abb1fe8463987ba25ed7ea4e781fa6 (patch)
treefe578537698932a56b5a5cbc3c4ba17af87e239a /toolchain
parent17ae95bb20297442a0f9df118e85c3a060fd59c3 (diff)
downloadmaster-31e0f0ae-8f57c55993abb1fe8463987ba25ed7ea4e781fa6.tar.gz
master-31e0f0ae-8f57c55993abb1fe8463987ba25ed7ea4e781fa6.tar.bz2
master-31e0f0ae-8f57c55993abb1fe8463987ba25ed7ea4e781fa6.zip
musl: fix build on sh3
musl fails to build when compiled with gcc on sh3 (GCC target/#67260). Work it around. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> SVN-Revision: 47012
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/musl/common.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/toolchain/musl/common.mk b/toolchain/musl/common.mk
index 82c15430a1..3045c634bc 100644
--- a/toolchain/musl/common.mk
+++ b/toolchain/musl/common.mk
@@ -23,6 +23,12 @@ HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/toolchain-build.mk
include $(INCLUDE_DIR)/hardening.mk
+# Please see https://gcc.gnu.org/bugzilla/show_bug.cgi?id=67260
+ifeq ($(CONFIG_sh3),y)
+TARGET_CFLAGS+= \
+ -fno-optimize-sibling-calls
+endif
+
MUSL_CONFIGURE:= \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \