summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-10 21:10:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-10 21:10:45 +0000
commit795cab69b3acef4f8eb5ae0f421ef6427b2d5c9b (patch)
treed25545bf84ec6d5940d90b99ef33001f02aff9c4 /toolchain
parent8a22f31c2528226926cef72d6507e7f20957def5 (diff)
downloadmaster-31e0f0ae-795cab69b3acef4f8eb5ae0f421ef6427b2d5c9b.tar.gz
master-31e0f0ae-795cab69b3acef4f8eb5ae0f421ef6427b2d5c9b.tar.bz2
master-31e0f0ae-795cab69b3acef4f8eb5ae0f421ef6427b2d5c9b.zip
gcc: enable LTO support unconditionally
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 47442
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/final/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/toolchain/gcc/final/Makefile b/toolchain/gcc/final/Makefile
index 1212d145ab..3434d894a2 100644
--- a/toolchain/gcc/final/Makefile
+++ b/toolchain/gcc/final/Makefile
@@ -8,13 +8,9 @@ GCC_CONFIGURE += \
--enable-languages=$(TARGET_LANGUAGES) \
--enable-shared \
--enable-threads \
- --with-slibdir=$(TOOLCHAIN_DIR)/lib
-
-ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
- GCC_CONFIGURE += \
+ --with-slibdir=$(TOOLCHAIN_DIR)/lib \
--enable-lto \
--with-libelf=$(TOPDIR)/staging_dir/host
-endif
ifdef CONFIG_USE_MUSL
GCC_MAKE += gcc_cv_libc_provides_ssp=yes