summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-25 14:12:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-25 14:12:44 +0000
commit6638374f5d3f70a9b82545161bc523fdc6808a34 (patch)
tree7cb006dfe5822887d8c15b06be84e47cd5522bac /toolchain
parent3fac6dde85cf00b5e4815438062d3710efb18105 (diff)
downloadmaster-31e0f0ae-6638374f5d3f70a9b82545161bc523fdc6808a34.tar.gz
master-31e0f0ae-6638374f5d3f70a9b82545161bc523fdc6808a34.tar.bz2
master-31e0f0ae-6638374f5d3f70a9b82545161bc523fdc6808a34.zip
gcc: make colors optional based on the GCC_COLORS env var
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 47642
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/common.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 0ac7de19f5..3e4f3ee984 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -151,6 +151,10 @@ ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
GCC_CONFIGURE += --with-mips-plt
endif
+ifndef GCC_VERSION_4_8
+ GCC_CONFIGURE += --with-diagnostics-color=auto-if-env
+endif
+
ifneq ($(CONFIG_SSP_SUPPORT),)
GCC_CONFIGURE+= \
--enable-libssp