summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2016-02-17 08:44:49 +0000
committerJo-Philipp Wich <jow@openwrt.org>2016-02-17 08:44:49 +0000
commit5445a2ee1d0ec8a42e16a68d03c69375da31ee82 (patch)
tree4ba1f3927f80818f157619025e5a4165dc8c1d15 /toolchain
parent83cdf722716fabee3864fcc7335561917452e0a0 (diff)
downloadmaster-31e0f0ae-5445a2ee1d0ec8a42e16a68d03c69375da31ee82.tar.gz
master-31e0f0ae-5445a2ee1d0ec8a42e16a68d03c69375da31ee82.tar.bz2
master-31e0f0ae-5445a2ee1d0ec8a42e16a68d03c69375da31ee82.zip
toolchain: use latest glibc 2.21 and 2.22 revisions
Refresh patches and rework Makefile to fetch glibc from release branches instead of relying on tarballs. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 48735
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/glibc/Config.version6
-rw-r--r--toolchain/glibc/common.mk34
-rw-r--r--toolchain/glibc/patches/2.21/200-add-dl-search-paths.patch2
-rw-r--r--toolchain/glibc/patches/2.22/200-add-dl-search-paths.patch2
4 files changed, 22 insertions, 22 deletions
diff --git a/toolchain/glibc/Config.version b/toolchain/glibc/Config.version
index 99ab7fd431..360045336d 100644
--- a/toolchain/glibc/Config.version
+++ b/toolchain/glibc/Config.version
@@ -16,12 +16,6 @@ config GLIBC_VERSION_2_22
default y if !TOOLCHAINOPTS
bool
-config GLIBC_REVISION
- string
- default "25243" if EGLIBC_VERSION_2_19
- default "4e42b5b8f8" if GLIBC_VERSION_2_21
- default ""
-
endif
menu "eglibc configuration"
diff --git a/toolchain/glibc/common.mk b/toolchain/glibc/common.mk
index 14063bf9df..042e63d510 100644
--- a/toolchain/glibc/common.mk
+++ b/toolchain/glibc/common.mk
@@ -1,27 +1,33 @@
#
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
+
+MD5SUM_2.19 = 42dad4edd3bcb38006d13b5640b00b38
+REVISION_2.19 = 25243
+
+MD5SUM_2.21 = 76050a65c444d58b5c4aa0d6034736ed
+REVISION_2.21 = 16d0a0c
+
+MD5SUM_2.22 = b575850e77b37d70f96472285290b391
+REVISION_2.22 = b995d95
+
+
PKG_NAME:=glibc
PKG_VERSION:=$(call qstrip,$(CONFIG_GLIBC_VERSION))
-ifeq ($(PKG_VERSION),2.22)
- PKG_SOURCE_URL:=http://ftpmirror.gnu.org/libc
- PKG_MD5SUM:=eb731406903befef1d8f878a46be75ef862b9056ab0cde1626d08a7a05328948
- PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
- PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.xz
-else
- PKG_REVISION:=$(call qstrip,$(CONFIG_GLIBC_REVISION))
- PKG_SOURCE_PROTO:=git
- PKG_SOURCE_URL:=git://sourceware.org/git/glibc.git
- PKG_SOURCE_VERSION:=$(PKG_REVISION)
- PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-r$(PKG_REVISION)
- PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.bz2
-endif
+PKG_REVISION:=$(REVISION_$(PKG_VERSION))
+PKG_MIRROR_MD5SUM:=$(MD5SUM_$(PKG_VERSION))
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://sourceware.org/git/glibc.git
+PKG_SOURCE_VERSION:=$(PKG_REVISION)
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_REVISION)
+PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.bz2
GLIBC_PATH:=
ifneq ($(CONFIG_EGLIBC_VERSION_2_19),)
diff --git a/toolchain/glibc/patches/2.21/200-add-dl-search-paths.patch b/toolchain/glibc/patches/2.21/200-add-dl-search-paths.patch
index a6200f783b..070f938fe3 100644
--- a/toolchain/glibc/patches/2.21/200-add-dl-search-paths.patch
+++ b/toolchain/glibc/patches/2.21/200-add-dl-search-paths.patch
@@ -2,7 +2,7 @@ add /usr/lib to default search path for the dynamic linker
--- a/Makeconfig
+++ b/Makeconfig
-@@ -501,6 +501,9 @@ else
+@@ -499,6 +499,9 @@ else
default-rpath = $(libdir)
endif
diff --git a/toolchain/glibc/patches/2.22/200-add-dl-search-paths.patch b/toolchain/glibc/patches/2.22/200-add-dl-search-paths.patch
index a6200f783b..d82686c079 100644
--- a/toolchain/glibc/patches/2.22/200-add-dl-search-paths.patch
+++ b/toolchain/glibc/patches/2.22/200-add-dl-search-paths.patch
@@ -2,7 +2,7 @@ add /usr/lib to default search path for the dynamic linker
--- a/Makeconfig
+++ b/Makeconfig
-@@ -501,6 +501,9 @@ else
+@@ -527,6 +527,9 @@ else
default-rpath = $(libdir)
endif