summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-09-20 20:49:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-09-20 20:49:34 +0000
commitffd00db938cd5792186b6bdebba3ea05c738c0d5 (patch)
treef18cbd8c9e6e7baefeac7d5016a9068a23caa523 /toolchain
parent7f80e266612c4ce1f17c7cbdfc268057de9ae58b (diff)
downloadmaster-31e0f0ae-ffd00db938cd5792186b6bdebba3ea05c738c0d5.tar.gz
master-31e0f0ae-ffd00db938cd5792186b6bdebba3ea05c738c0d5.tar.bz2
master-31e0f0ae-ffd00db938cd5792186b6bdebba3ea05c738c0d5.zip
gcc: enable non-PIC for mips targets in gcc 4.4+ to reduce code size
SVN-Revision: 23103
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/common.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 645cf60d1d..e2277207b8 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -122,6 +122,12 @@ GCC_CONFIGURE:= \
$(if $(CONFIG_GCC_VERSION_LLVM),--enable-llvm=$(BUILD_DIR_BASE)/host/llvm) \
$(if $(CONFIG_GCC_VERSION_4_3_3_CS)$(CONFIG_GCC_VERSION_4_4_1_CS)$(CONFIG_GCC_VERSION_4_4_3_CS),--enable-poison-system-directories)
+ifneq ($(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5),)
+ ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
+ GCC_CONFIGURE += --with-mips-plt
+ endif
+endif
+
ifneq ($(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5),)
GCC_BUILD_TARGET_LIBGCC:=y
GCC_CONFIGURE+= \