summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-24 00:58:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-24 00:58:34 +0000
commite7c0b6aa00e46bbbe64c00e3104efe9d5be05196 (patch)
treeb36cb66b7646c96714318bfa3828af9dc38f29fa /toolchain
parent5b2c123b601459bbc05e9e27ed3f1c86b89c3eb2 (diff)
downloadmaster-31e0f0ae-e7c0b6aa00e46bbbe64c00e3104efe9d5be05196.tar.gz
master-31e0f0ae-e7c0b6aa00e46bbbe64c00e3104efe9d5be05196.tar.bz2
master-31e0f0ae-e7c0b6aa00e46bbbe64c00e3104efe9d5be05196.zip
gcc: fix bug reporting url in newer compiler versions
SVN-Revision: 18130
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index 0970b2f985..161c7894a5 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -253,13 +253,16 @@ define Stage2/Install
endef
+BUGURL=https://dev.openwrt.org/
+
define Host/Prepare
$(call Host/SetToolchainInfo)
$(call Host/Prepare/Default)
ln -snf $(GCC_DIR) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
$(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/
$(SED) 's,\(version_string.. = "[0-9\.]*\).*\(";\),\1 (OpenWrt-2.0)\2,' $(HOST_BUILD_DIR)/gcc/version.c
- $(SED) 's,\(bug_report_url.. = "\).*\(";\),\1<URL:https://dev.openwrt.org/>\2,' $(HOST_BUILD_DIR)/gcc/version.c
+ $(SED) 's,\(bug_report_url.. = "\).*\(";\),\1<URL:$(BUGURL)>\2,' $(HOST_BUILD_DIR)/gcc/version.c
+ $(SED) 's,http://gcc.gnu.org/bugs.html,$(BUGURL),' $(HOST_BUILD_DIR)/gcc/configure
#(cd $(HOST_BUILD_DIR)/libstdc++-v3; autoconf;);
$(SED) 's,gcc_no_link=yes,gcc_no_link=no,' $(HOST_BUILD_DIR)/libstdc++-v3/configure
$(call Stage0/Configure)