summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-08 13:10:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-08 13:10:11 +0000
commite52b720870c23511cfc9323a784694c9dd24a0ab (patch)
tree7e618d0e20a26660f596f58c283cab7982e6c7d6 /toolchain
parentfa6e1dd37d33ffcba9d1fdf74d1c9f472a078da1 (diff)
downloadmaster-31e0f0ae-e52b720870c23511cfc9323a784694c9dd24a0ab.tar.gz
master-31e0f0ae-e52b720870c23511cfc9323a784694c9dd24a0ab.tar.bz2
master-31e0f0ae-e52b720870c23511cfc9323a784694c9dd24a0ab.zip
gcc: move the optimized assembler helpers back into the static libgcc and skip relinking for this arch. due to relocation constraints, the assembler functions cannot be in the shared libgcc and must always be linked in statically
SVN-Revision: 25952
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/patches/linaro/850-use_shared_libgcc.patch31
1 files changed, 11 insertions, 20 deletions
diff --git a/toolchain/gcc/patches/linaro/850-use_shared_libgcc.patch b/toolchain/gcc/patches/linaro/850-use_shared_libgcc.patch
index a9cc80bfe0..5e33c9d4e1 100644
--- a/toolchain/gcc/patches/linaro/850-use_shared_libgcc.patch
+++ b/toolchain/gcc/patches/linaro/850-use_shared_libgcc.patch
@@ -35,18 +35,6 @@
/* Determine which dynamic linker to use depending on whether GLIBC or
uClibc is the default C library and whether -muclibc or -mglibc has
been passed to change the default. */
---- a/gcc/config/rs6000/ppc-asm.h
-+++ b/gcc/config/rs6000/ppc-asm.h
-@@ -325,8 +325,7 @@
- FUNC_NAME(name):
-
- #define HIDDEN_FUNC(name) \
-- FUNC_START(name) \
-- .hidden FUNC_NAME(name);
-+ FUNC_START(name);
-
- #define FUNC_END(name) \
- GLUE(.L,name): \
--- a/gcc/mkmap-symver.awk
+++ b/gcc/mkmap-symver.awk
@@ -132,5 +132,5 @@
@@ -56,14 +44,6 @@
- printf ("\n local:\n\t*;\n};\n");
+ printf ("\n\t*;\n};\n");
}
---- a/libgcc/config/rs6000/t-ppccomm
-+++ b/libgcc/config/rs6000/t-ppccomm
-@@ -1,4 +1,4 @@
--LIB2ADD_ST += crtsavfpr.S crtresfpr.S \
-+LIB2ADD += crtsavfpr.S crtresfpr.S \
- crtsavgpr.S crtresgpr.S \
- crtresxfpr.S crtresxgpr.S \
- e500crtres32gpr.S \
--- a/libgcc/Makefile.in
+++ b/libgcc/Makefile.in
@@ -265,7 +265,7 @@
@@ -75,3 +55,14 @@
ifneq (,$(vis_hide))
+--- a/gcc/config/rs6000/linux.h
++++ b/gcc/config/rs6000/linux.h
+@@ -85,6 +85,8 @@
+ #define USE_LD_AS_NEEDED 1
+ #endif
+
++#define LIBGCC_SPEC "%{!static:%{!static-libgcc:-lgcc_s}} -lgcc"
++
+ #undef TARGET_VERSION
+ #define TARGET_VERSION fprintf (stderr, " (PowerPC GNU/Linux)");
+