summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2011-07-02 07:50:26 +0000
committerImre Kaloz <kaloz@openwrt.org>2011-07-02 07:50:26 +0000
commita2c039457292e65cd2bdaa468454daac7c38ffc3 (patch)
tree5029d4837cb6501c56008e0d423bfbb3c07b3b50 /toolchain
parent7845c7b5124c9d14483a2a9bec997b3e9a6d1620 (diff)
downloadmaster-31e0f0ae-a2c039457292e65cd2bdaa468454daac7c38ffc3.tar.gz
master-31e0f0ae-a2c039457292e65cd2bdaa468454daac7c38ffc3.tar.bz2
master-31e0f0ae-a2c039457292e65cd2bdaa468454daac7c38ffc3.zip
simplify configuration
SVN-Revision: 27353
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Config.in2
-rw-r--r--toolchain/gcc/common.mk15
2 files changed, 5 insertions, 12 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 556a56955f..75d388dc65 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -25,7 +25,7 @@ endchoice
config GCC_USE_GRAPHITE
bool
prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
- depends GCC_VERSION_4_4 || GCC_VERSION_4_5 || GCC_VERSION_4_6
+ depends !GCC_VERSION_LLVM
config GCC_USE_SYSTEM_PPL_CLOOG
bool
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 2762f6ad09..d2177c5468 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -104,27 +104,20 @@ GCC_CONFIGURE:= \
$(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
$(if $(CONFIG_GCC_VERSION_LLVM),--enable-llvm=$(BUILD_DIR_BASE)/host/llvm) \
-ifneq ($(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
- ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
- GCC_CONFIGURE += --with-mips-plt
- endif
-endif
-
ifeq ($(CONFIG_GCC_LLVM),)
GCC_BUILD_TARGET_LIBGCC:=y
GCC_CONFIGURE+= \
--with-gmp=$(TOPDIR)/staging_dir/host \
--with-mpfr=$(TOPDIR)/staging_dir/host \
--disable-decimal-float
+ ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
+ GCC_CONFIGURE += --with-mips-plt
+ endif
endif
ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
- GCC_BUILD_TARGET_LIBGCC:=y
GCC_CONFIGURE+= \
- --with-gmp=$(TOPDIR)/staging_dir/host \
- --with-mpc=$(TOPDIR)/staging_dir/host \
- --with-mpfr=$(TOPDIR)/staging_dir/host \
- --disable-decimal-float
+ --with-mpc=$(TOPDIR)/staging_dir/host
endif
ifneq ($(CONFIG_SSP_SUPPORT),)