summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-10-23 06:23:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-10-23 06:23:17 +0000
commit5feb978446bd193b0b4504ab335402041e71678b (patch)
tree636467512e8807c1cb575a9703869a3143d64822 /toolchain
parentd8e032edef2fb9d1f7aa3b1f96a444f0a1db9696 (diff)
downloadmaster-31e0f0ae-5feb978446bd193b0b4504ab335402041e71678b.tar.gz
master-31e0f0ae-5feb978446bd193b0b4504ab335402041e71678b.tar.bz2
master-31e0f0ae-5feb978446bd193b0b4504ab335402041e71678b.zip
openwrt: honour gcc extra configuration flags
Although the CONFIG_EXTRA_GCC_OPTIONS flag is available, it isn't used anywhere. This change adds the extra flag to both gcc configure stages. Signed-off-by: Jeremy Kerr <jk@ozlabs.org> SVN-Revision: 9406
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index a326bb716f..d9e34af0bd 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -60,6 +60,7 @@ define Stage1/Configure
--disable-nls \
--disable-libmudflap \
--disable-multilib \
+ $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
);
endef
define Stage1/Compile
@@ -91,6 +92,7 @@ define Stage2/Configure
--disable-nls \
--disable-libmudflap \
--disable-multilib \
+ $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
);
endef