summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-10-12 14:42:41 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-10-12 14:42:41 +0000
commit3b683b6feb2500801ea005edf8220111ae253cd8 (patch)
tree034089e02e1c0986a3b0893aa394823b0dd6b539 /toolchain
parent154123a8c67ad4c5f7ece55053edc2396b9675c9 (diff)
downloadmaster-31e0f0ae-3b683b6feb2500801ea005edf8220111ae253cd8.tar.gz
master-31e0f0ae-3b683b6feb2500801ea005edf8220111ae253cd8.tar.bz2
master-31e0f0ae-3b683b6feb2500801ea005edf8220111ae253cd8.zip
gcc: add --with-long-double-128 for SPARC toolchain
This is required in order to build the final compiler. SVN-Revision: 33739
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/common.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index c18a330f34..53e4635df4 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -123,6 +123,7 @@ GCC_CONFIGURE:= \
$(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
$(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
$(if $(CONFIG_GCC_VERSION_LLVM),--enable-llvm=$(BUILD_DIR_BASE)/host/llvm) \
+ $(if $(CONFIG_sparc),--with-long-double-128) \
ifeq ($(CONFIG_GCC_LLVM),)
GCC_BUILD_TARGET_LIBGCC:=y