summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-04-10 14:05:38 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-04-10 14:05:38 +0000
commit3630b457a5812a89e8c206e5d5ed567e903627e5 (patch)
tree3eefc46430190cf8e1dff822963a2cb0bd7ae91c /toolchain
parent9c3033370a92a022496118fed4471a3f8431fc94 (diff)
downloadmaster-31e0f0ae-3630b457a5812a89e8c206e5d5ed567e903627e5.tar.gz
master-31e0f0ae-3630b457a5812a89e8c206e5d5ed567e903627e5.tar.bz2
master-31e0f0ae-3630b457a5812a89e8c206e5d5ed567e903627e5.zip
Disable tls support, uClibc does not support it, and it could lead to linking failures with some braindead autoconf programs
SVN-Revision: 10782
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index a1d1baa400..57118bb119 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -60,6 +60,7 @@ define Stage1/Configure
--disable-nls \
--disable-libmudflap \
--disable-multilib \
+ --disable-tls \
$(SOFT_FLOAT_CONFIG_OPTION) \
$(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
);
@@ -93,6 +94,7 @@ define Stage2/Configure
--disable-nls \
--disable-libmudflap \
--disable-multilib \
+ --disable-tls \
$(SOFT_FLOAT_CONFIG_OPTION) \
$(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
);