summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-01-13 02:15:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-01-13 02:15:14 +0000
commit087a2bc16c82ab6559cb4000d05eb796c3649006 (patch)
treed4de9a32a5ea21da1c86f11223e1848817af3775 /toolchain
parent6fb293c05be0f09e99381904b4e4d3995ff8a0c6 (diff)
downloadmaster-31e0f0ae-087a2bc16c82ab6559cb4000d05eb796c3649006.tar.gz
master-31e0f0ae-087a2bc16c82ab6559cb4000d05eb796c3649006.tar.bz2
master-31e0f0ae-087a2bc16c82ab6559cb4000d05eb796c3649006.zip
uclibc: add some libpthread fixes
SVN-Revision: 14013
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/uClibc/patches/190-install_tls.patch12
-rw-r--r--toolchain/uClibc/patches/200-libpthread_static.patch11
2 files changed, 23 insertions, 0 deletions
diff --git a/toolchain/uClibc/patches/190-install_tls.patch b/toolchain/uClibc/patches/190-install_tls.patch
new file mode 100644
index 0000000000..74d403265c
--- /dev/null
+++ b/toolchain/uClibc/patches/190-install_tls.patch
@@ -0,0 +1,12 @@
+--- a/libpthread/linuxthreads/Makefile.in
++++ b/libpthread/linuxthreads/Makefile.in
+@@ -128,7 +128,9 @@ linuxthreads_headers:
+ $(Q)$(LN) -sf ../$(PTDIR)/sysdeps/pthread/pthread.h $(top_builddir)include/
+ $(Q)$(LN) -sf ../$(PTDIR)/semaphore.h $(top_builddir)include/
+ $(Q)$(INSTALL) -d $(top_builddir)include/bits
++ $(Q)$(INSTALL) -d $(top_builddir)include/sys
+ $(Q)$(LN) -sf ../../$(PTDIR)/sysdeps/pthread/bits/pthreadtypes.h $(top_builddir)include/bits/
++ $(Q)$(LN) -sf ../../$(PTDIR)/sysdeps/$(TARGET_ARCH)/tls.h $(top_builddir)include/sys/
+
+ linuxthreads_headers_clean:
+ $(RM) $(top_builddir)include/pthread.h $(top_builddir)include/semaphore.h \
diff --git a/toolchain/uClibc/patches/200-libpthread_static.patch b/toolchain/uClibc/patches/200-libpthread_static.patch
new file mode 100644
index 0000000000..269370d075
--- /dev/null
+++ b/toolchain/uClibc/patches/200-libpthread_static.patch
@@ -0,0 +1,11 @@
+--- a/libpthread/linuxthreads/Makefile.in
++++ b/libpthread/linuxthreads/Makefile.in
+@@ -65,7 +65,7 @@ CFLAGS-OMIT-libc_pthread_init.c := $(CFL
+ libpthread_libc_CSRC := \
+ forward.c libc-cancellation.c libc_pthread_init.c # alloca_cutoff.c
+ libpthread_libc_OBJ := $(patsubst %.c, $(libpthread_OUT)/%.o,$(libpthread_libc_CSRC))
+-libc-static-y += $(libpthread_OUT)/libc_pthread_init.o
++libc-static-y += $(libpthread_OUT)/libc_pthread_init.o $(libpthread_OUT)/libc-cancellation.o
+ libc-shared-y += $(libpthread_libc_OBJ:.o=.oS)
+
+ libpthread-static-y += $(patsubst %,$(libpthread_OUT)/%.o,$(libpthread_static_SRC))