summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-08-13 16:26:58 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-08-13 16:26:58 +0000
commit0143069883570a16f11542d0a7bb463aa3573f96 (patch)
tree1192c1e00c9efe597d799b650d166d1946440733 /toolchain
parentd0edc434ab65961c24726da838e1f5d588558eac (diff)
downloadmaster-31e0f0ae-0143069883570a16f11542d0a7bb463aa3573f96.tar.gz
master-31e0f0ae-0143069883570a16f11542d0a7bb463aa3573f96.tar.bz2
master-31e0f0ae-0143069883570a16f11542d0a7bb463aa3573f96.zip
Fix the stage2 compilation, no side effect with gcc4 (#2190)
SVN-Revision: 8409
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index cd18098e9f..bae9220f0c 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -93,9 +93,7 @@ define Stage2/Configure
endef
define Stage2/Compile
- $(MAKE) -C $(BUILD_DIR2) \
- SHELL="$(BASH)" \
- all
+ export SHELL="\$(BASH)"; \$(MAKE) -C \$(BUILD_DIR2) all
endef
define Stage2/Install