summaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-06-30 07:54:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-06-30 07:54:51 +0000
commit02a6750af87091e69d8c14e4b9e73c960b4d5794 (patch)
tree5f81f71560f350d1f6635508265a5583cf0182f8 /toolchain/uClibc
parent98df29f9d7598cb4f84d284b41ffc3e755d8f95c (diff)
downloadmaster-31e0f0ae-02a6750af87091e69d8c14e4b9e73c960b4d5794.tar.gz
master-31e0f0ae-02a6750af87091e69d8c14e4b9e73c960b4d5794.tar.bz2
master-31e0f0ae-02a6750af87091e69d8c14e4b9e73c960b4d5794.zip
uClibc: use position independent code for crt1, slightly reduces size of all executables
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 37096
Diffstat (limited to 'toolchain/uClibc')
-rw-r--r--toolchain/uClibc/patches-0.9.33.2/210-mips_use_pic_crt1.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/toolchain/uClibc/patches-0.9.33.2/210-mips_use_pic_crt1.patch b/toolchain/uClibc/patches-0.9.33.2/210-mips_use_pic_crt1.patch
new file mode 100644
index 0000000000..2ca10d47cc
--- /dev/null
+++ b/toolchain/uClibc/patches-0.9.33.2/210-mips_use_pic_crt1.patch
@@ -0,0 +1,11 @@
+--- a/libc/sysdeps/linux/mips/Makefile.arch
++++ b/libc/sysdeps/linux/mips/Makefile.arch
+@@ -20,6 +20,8 @@ ifneq ($(UCLIBC_HAS_THREADS_NATIVE),y)
+ SSRC += vfork.S clone.S
+ endif
+
++CFLAGS-crt1.S += $(PICFLAG)
++
+ ASFLAGS-syscall_error.S += -D_LIBC_REENTRANT
+
+ ARCH_HEADERS := sgidefs.h