summaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-06-26 14:22:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-06-26 14:22:55 +0000
commit92726d8f3243ac2e91823ba4c3c1e66cec083581 (patch)
treec16f3b6669eba30dc1feca90e00a99eba1bf226b /toolchain/uClibc
parentce50bb163606bbd62d1724c341a0a0cfcda5f44e (diff)
downloadmaster-31e0f0ae-92726d8f3243ac2e91823ba4c3c1e66cec083581.tar.gz
master-31e0f0ae-92726d8f3243ac2e91823ba4c3c1e66cec083581.tar.bz2
master-31e0f0ae-92726d8f3243ac2e91823ba4c3c1e66cec083581.zip
uclibc: make powerpc e500 support independent of the target name, always use it if the spe_fpu feature flag is set
SVN-Revision: 27289
Diffstat (limited to 'toolchain/uClibc')
-rw-r--r--toolchain/uClibc/Makefile4
-rw-r--r--toolchain/uClibc/config-0.9.32/powerpc.e500 (renamed from toolchain/uClibc/config-0.9.32/powerpc.mpc85xx)0
2 files changed, 3 insertions, 1 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index 21a180c225..d74d1ecfc8 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -59,7 +59,9 @@ endef
GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n \
$(if $(wildcard $(CONFIG_DIR)/common),'+' $(CONFIG_DIR)/common) \
$(if $(CONFIG_UCLIBC_ENABLE_DEBUG),$(if $(wildcard $(CONFIG_DIR)/debug),'+' $(CONFIG_DIR)/debug)) \
- $(CONFIG_DIR)/$(ARCH)$(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD))
+ $(CONFIG_DIR)/$(ARCH)$(strip \
+ $(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD), \
+ $(if $(CONFIG_HAS_SPE_FPU),$(if $(wildcard $(CONFIG_DIR)/$(ARCH).e500),.e500))))
define Host/Prepare
$(call Host/Prepare/Default)
diff --git a/toolchain/uClibc/config-0.9.32/powerpc.mpc85xx b/toolchain/uClibc/config-0.9.32/powerpc.e500
index a835c3d5e7..a835c3d5e7 100644
--- a/toolchain/uClibc/config-0.9.32/powerpc.mpc85xx
+++ b/toolchain/uClibc/config-0.9.32/powerpc.e500