summaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-01 05:41:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-01 05:41:02 +0000
commit783e0646320b311ea6b03f9d01fd61bb48cd427d (patch)
tree8421def698fc57635ff9f33775cbaf6a7fd318d6 /toolchain/uClibc
parentfa74dadda82dd4c9a348e21727575f526d6fc961 (diff)
downloadmaster-31e0f0ae-783e0646320b311ea6b03f9d01fd61bb48cd427d.tar.gz
master-31e0f0ae-783e0646320b311ea6b03f9d01fd61bb48cd427d.tar.bz2
master-31e0f0ae-783e0646320b311ea6b03f9d01fd61bb48cd427d.zip
uClibc: set the toolchain info at install time instead of prepare time, fixes staging dir rebuilds
SVN-Revision: 25803
Diffstat (limited to 'toolchain/uClibc')
-rw-r--r--toolchain/uClibc/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index 0ce9554e78..642f7fba4c 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -62,7 +62,6 @@ GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n \
$(CONFIG_DIR)/$(ARCH)$(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD))
define Host/Prepare
- $(call Host/SetToolchainInfo)
$(call Host/Prepare/Default)
$(if $(strip $(QUILT)), \
cd $(HOST_BUILD_DIR); \
@@ -132,6 +131,7 @@ define Host/Compile
endef
define Host/Install
+ $(call Host/SetToolchainInfo)
$(UCLIBC_MAKE) PREFIX= utils
$(INSTALL_DIR) $(TOOLCHAIN_DIR)/bin
$(INSTALL_BIN) \