summaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-30 22:01:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-30 22:01:29 +0000
commit726e929a95a9fac55469d12a77e58f81950d985a (patch)
tree144ea5eb0acf72c7b1926479bf06cde3b4b0536d /toolchain/uClibc
parenta37c85d5fe575cf36531ba255976d9fed5fcdbf5 (diff)
downloadmaster-31e0f0ae-726e929a95a9fac55469d12a77e58f81950d985a.tar.gz
master-31e0f0ae-726e929a95a9fac55469d12a77e58f81950d985a.tar.bz2
master-31e0f0ae-726e929a95a9fac55469d12a77e58f81950d985a.zip
fix an uClibc compile error that only happens on rebuilds
SVN-Revision: 8248
Diffstat (limited to 'toolchain/uClibc')
-rw-r--r--toolchain/uClibc/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index 7fce989542..d6ef6a3438 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -37,7 +37,6 @@ UCLIBC_TARGET_ARCH:=$(shell echo $(ARCH) | sed -e s'/-.*//' \
define Build/Prepare
$(call Build/Prepare/Default)
- $(SED) 's,^CROSS=.*,CROSS=$(TARGET_CROSS),g' $(PKG_BUILD_DIR)/Rules.mak
if [ -e config/$(ARCH).$(BOARD) ]; then \
$(CP) config/$(ARCH).$(BOARD) $(PKG_BUILD_DIR)/.config; \
else \
@@ -73,6 +72,7 @@ define Build/Configure
endef
define Build/Compile
+ $(SED) 's,^CROSS=.*,CROSS=$(TARGET_CROSS),g' $(PKG_BUILD_DIR)/Rules.mak
PATH=$(TARGET_PATH) $(MAKE) -j $(CONFIG_JLEVEL) -C $(PKG_BUILD_DIR) \
PREFIX= \
DEVEL_PREFIX=/ \