summaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-07-21 10:41:27 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-07-21 10:41:27 +0000
commit3d9c4c9073deaf01d592d6940af21be81d92e88a (patch)
tree8b9a10a8f3449e92fdf6418655d8d1e2d62817bc /toolchain/uClibc
parent7f358023bcc6f56ed1b8382c2c943604026600c0 (diff)
downloadmaster-31e0f0ae-3d9c4c9073deaf01d592d6940af21be81d92e88a.tar.gz
master-31e0f0ae-3d9c4c9073deaf01d592d6940af21be81d92e88a.tar.bz2
master-31e0f0ae-3d9c4c9073deaf01d592d6940af21be81d92e88a.zip
uClibc for x86 targets and kernels >= 2.6.24 need to copy the right include files, remove this when there are no 2.6.23 left
SVN-Revision: 11893
Diffstat (limited to 'toolchain/uClibc')
-rw-r--r--toolchain/uClibc/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index 8c02489b14..197f736d1e 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -64,6 +64,13 @@ UCLIBC_TARGET_ARCH:=$(shell echo $(ARCH) | sed -e s'/-.*//' \
-e 's/cris.*/cris/' \
)
+# Remove me when there are no 2.6.23 targets
+ifeq ($(findstring 86,$(ARCH)),86)
+ ifneq ($(LINUX_2_6_23),y)
+ UCLIBC_TARGET_ARCH:=x86
+ endif
+endif
+
define Build/Prepare/Snapshot
$(PKG_UNPACK)
rm -Rf $(PKG_BUILD_DIR)